show blocked popup, new windows open in tabs, popup menu goes deaf

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: g.teunis, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---
Bug Flags:
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

When "Force links that open new windows to op in" is set to "a new tab" the
'Show popup' breaks (very bad). 
The first use of Show popup (lower right corner) will show the popup but will
disable keyboard input. 
The keyboard focus is still on the invisible "Show popup" menu or sometimes will
crash browser on keypress.


Reproducible: Always
Steps to Reproduce:
1. Set "Force links that open new windows to op in" to "a new tab"
2. open a site with popups (like www.NGemu.com)
3. click on lower-right popup icon and use "Show...(popupname)"
4. Now try to Show it again! (step 4 again)
5. Try to enter URL or pressing some keys

Actual Results:  
Keyboard input is ignored, sometimes the pressed key is used to open a menu-item
in de (invisible) Show Popup menu.

Expected Results:  
The Show popup menu should be still working and keyboard should be usable.
(Reporter)

Comment 1

14 years ago
Pressing keys when the popup opened from www.ngemu.com is focussed will crash
the browser.
(Reporter)

Comment 2

14 years ago
The www.ngemu.com popups are too aggressive (fullscreen resize etc)
Please use: http://www.popuptest.com/popuptest1.html
(Sorry for the bugspam)
Not confirmed.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041101 Firefox/1.0RC2
(daihard: P4/SSE2)

Bonsai shows nothing obvious between my build and yours.
(Reporter)

Comment 4

14 years ago
(In reply to comment #3)
> Not confirmed.
>
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041101 Firefox/1.0RC2
> (daihard: P4/SSE2)
>
> Bonsai shows nothing obvious between my build and yours.

I think might be Windows only. I've submitted the talkback data.
(you have to press a key on the manually opened tab to crash the browser)

Talkback ID: 1721939

Comment 5

14 years ago
Confirmed using Firefox 1.0RC2 on Windows XP. With new windows forced into tabs,
go to http://www.popuptest.com/popuptest1.html and use the popup icon menu to
open one of the six blocked popups. The window opens into a new tab. At this point:

* With the popup tab active, press any key. Firefox crashes.
* With the first (popuptest1.html) tab active, a mouseclick on the popup
  icon has no effect. If you press any key that corresponds to
  a shortcut in the popup icon menu (P, E, or D in English versions),
  the corresponding menu command is executed. Now a mouseclick on
  the popup icon once again opens the menu. Return to the popup tab and
  type a key, Firefox crashes.

Note Firefox Aviary 20041108 behaves rather differently. It won't crash and
keystrokes won't execute the menu commands. It seems an errant context menu has
been properly closed. However from now on the popup icon menu ignores
mouseclicks. It appears there's nothing you can do to ever get the popup icon
menu to open again in that window. I'm adjusting this bug's summary and
downgrading its severity to reflect the state of current builds.
Severity: critical → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Force new window links to open in tabs breaks Show Popup → show blocked popup, new windows open in tabs, popup menu goes deaf
Version: unspecified → 1.0 Branch
The difference between RC2 and 20041108 is likely to be the checkin for bug 266822

Comment 7

14 years ago
where do i find the Set "Force links that open new windows to open in a new tab"
option?

(Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0)
(Reporter)

Comment 8

14 years ago
Crashing seems to be fixed(?), but still not opening a popup on first tab after
opening one.
Flags: blocking-aviary1.1?
Flags: blocking-aviary1.1? → blocking-aviary1.1+
(Reporter)

Comment 9

14 years ago
Sorry for requesting for blocking-aviary1.1.
This bug is 1.0 Branch only, the trunk builds do not have this bug.
So it will not block the 1.1 release at all (1.1 will branch from the current
trunk right?)
Should I nominate it for 1.0.2?
(In reply to comment #9)
> This bug is 1.0 Branch only, the trunk builds do not have this bug.

WFM as well using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050331
Firefox/1.0+

Updated

14 years ago
Flags: blocking-aviary1.1+ → blocking-aviary1.1-
Assignee: bugs → nobody
Well, either way, 1.0.x has left the building.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.