javascript this.form.something.value does not work on input fields if is active

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: David Nordenberg, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041015 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041015 Firefox/0.10.1

It seems like you can't change a input field with javascript if the coursor is
standing in it, atleast I think that is what is causing it to malfunction. Well
demonstrated in the url attached. IE autocompletes the word while having coursor
in the input field but not firefox and I seen this bug on many many other forms
out there so its not a bug with just this script.

Reproducible: Always
Steps to Reproduce:
1. Try type "g" in the input field in the url attached
2. IE autocompletes to "george" but not firefox
Actual Results:  
Nothing

Expected Results:  
The field should say "george"
At least in that example it's nothing to do with the input being focused - when
the description says "(in IE)" it means "I wrote this only working with the IE
event model and the IE DOM0 method for getting and setting selections in
textinputs, not trying to be cross-browser" (quite possibly because selection in
Moz didn't work all that well before 2003 - it's undated and who knows how old
it is).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.