Program icon invisible when background color is the same as icon color

RESOLVED FIXED in Future

Status

P3
minor
RESOLVED FIXED
19 years ago
14 years ago

People

(Reporter: henrik, Assigned: law)

Tracking

({verifyme})

Trunk
Future
x86
Windows 98
verifyme

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
hi :-)

The Program icon in windows (32) is very nice, except its background color is 
the same as the background color in the Quick Launch bar. This makes the icon 
"almost" invisible. Almost since i can see some dark grey lines.

Comment 1

19 years ago
This occurs on the Windows startmenu and file explorer as well.
The problem seems to be that the background is transparent and the foreground is
very close to the default Windows button color, which is used on the startmenu
 and it's too bright for file explorer, which uses a white background.

Comment 2

19 years ago
Moving all UE/UI bugs to new component: User Interface: Design Feedback
UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback

Comment 3

19 years ago
Mozillazine has an icon page up - http://www.mozillazine.org/chrome/icons.html.
I'm using the moz-communicator.ico icon from the Windows list as my desktop
icon, and it looks pretty good.  If even temporary, this would be better than
the gray M, I think.

Comment 4

19 years ago
I thought this one was fixed with the new icons in the mozilla build. Can we 
mark this one fixed?
eli?

Comment 5

19 years ago
*** Bug 29060 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
This issue remains on 2000031008 Win32 Mozilla build.

Comment 7

19 years ago
*** Bug 29316 has been marked as a duplicate of this bug. ***

Comment 8

19 years ago
Basically, the main point of all these program icon bugs are that the icons at 
least on windows suck for mozilla right now.  Mozillazine has a ton of icons, in 
http://www.mozillazine.org/jason/icons/, http://www.mozillazine.org/splash/, 
and http://www.mozillazine.org/chrome/icons.html .  Lots of good icons, yet we 
still have an awful grey icon for moz.  If any work needs to be done on these, i 
can do it, just drop me a line with a choice, and i can fix em up for you.

Comment 9

19 years ago
reassign it to don to find an eng. owner. we'll need an engineer to own this bug 
for mozilla. don, anyone from your group? Mozillazine has many newly modified 
desktop icons that's better than what we have for mozilla build. But I dont kow 
who can check in the icons. 
Assignee: shuang → don

Comment 10

19 years ago
Just to chime in here, the Windows icon is nigh-unusable when added to the Quick 
Launch bar, which is going to be (based on 4.x experience) something that will 
eventually automatically be done by the commercial installer. Would someone 
please fix this? Thanks.

Comment 11

19 years ago
*** Bug 31966 has been marked as a duplicate of this bug. ***

Comment 12

19 years ago
I submitted MozillaZine some icons for Mozilla 
(http://www.mozillazine.org/chrome/icons.html), but the newest ones are at:
http://au.4mg.com/moz.htm
I've also had many problems with the current icon. It becomes distorted and 
unrecognizable when its in 16x16 form (normal is 32x32, Windows shrinks it for 
the toolbar and in the upper-left)- I think I fixed it in moz-m_gray.ico

Comment 13

19 years ago
Moving to XPApps.

I'm violating bug etiquette and assigning it a target milestone myself, so that 
it appears on Don's radar screen.

CC:ing Ben, in case he knows someone more appropriate than Don for adding new 
Mozilla Win32 icons (irregardless of which set they are.)
Component: User Interface: Design Feedback → XPApps
Target Milestone: --- → M16

Comment 14

19 years ago
Reassigning for Don
Assignee: don → law
Target Milestone: M16 → M18

Comment 15

19 years ago
Move to M21 target milestone.
Target Milestone: M18 → M21

Updated

18 years ago
QA Contact: elig → sairuh

Comment 16

18 years ago
nav triage team:

This bug looks a little old; the mozilla app icon is now the long tail gecko. 
Looks ok on taskbar under win2k. Not stopping beta1 for this. Marking nsbeta1-
Keywords: nsbeta1-

Comment 17

18 years ago
It may look okay on the taskbar, but the desktop icon in the 0.7 version is
almost invisible on the default Windows background colour.

Comment 18

18 years ago
If we want to ensure that the icon shows up on most desktop and toolbar
background color schemes, we need a multi-color icon and preferably one with a
dark border.  The current icon fails on both accounts.

I use moz-communicator.ico from AU's page (http://au.4mg.com/moz.htm) on my
desktop, and I quite like it.

Comment 19

18 years ago
<copy and pasted from the mozilla wishlist newsgroup>

There is actually a second icon (that i found because i like having 
choices) included in Mozilla:
create a windows shortcut
right click the icon and choose properties
go to change icon
choose browse, browse to "D:\Program Files\mozilla\mozctl.dll" and you 
will get the choice of a the head of the Mozilla mascot/lizard whatever 
its called.

Comment 20

18 years ago
if it's green [and ~it's not easy being green~] then it's (c) netscape and we 
can't use it. Yes I already asked about that critter. sorry :-(

Comment 21

18 years ago
Marking nsbeta1- bugs as future to get off the radar.
Target Milestone: --- → Future

Comment 22

18 years ago
*** Bug 87973 has been marked as a duplicate of this bug. ***

Comment 23

18 years ago
this has been seen on the desktop too, maybe Mozilla needs a more colorful icon?

In bug 87973 the suggestion was to outline the icon.

Summary: Program icon invisible in Windows Quick launch bar → Program icon invisible when background color is the same as icon color

Comment 24

18 years ago
Created attachment 40262 [details]
Lizard with black outline

Comment 25

18 years ago
Currently we are not changing any icons. No one likes that position but the 
problem relates to copyright and legal issues.  No new green creatures will be 
accepted. Please read the bug report before commenting. And in the case of this 
bug report there is probably no reason to comment until someone explains the 
legal position.
*** Bug 108815 has been marked as a duplicate of this bug. ***

Comment 27

17 years ago
*** Bug 111295 has been marked as a duplicate of this bug. ***

Comment 28

17 years ago
Does the RED lizard logo (red lizard facing right) violate any of Netscape's
copyrights?
*** Bug 112204 has been marked as a duplicate of this bug. ***

Comment 30

17 years ago
The problem is, on NT4, with the default background, you cannot see
the Mozilla icon !
*** Bug 137370 has been marked as a duplicate of this bug. ***

Comment 32

17 years ago
*** Bug 145088 has been marked as a duplicate of this bug. ***

Comment 33

17 years ago
*** Bug 147323 has been marked as a duplicate of this bug. ***
*** Bug 147688 has been marked as a duplicate of this bug. ***

Comment 35

17 years ago
*** Bug 149822 has been marked as a duplicate of this bug. ***
*** Bug 155054 has been marked as a duplicate of this bug. ***

Comment 37

17 years ago
*** Bug 160035 has been marked as a duplicate of this bug. ***

Comment 38

17 years ago
Icons were changed recently.  I don't use the installer, but I assume the icon
on the desktop is now the red mozilla head on the blue triangle.  Can someone
confirm that this appears properly now on the NT desktop?

Comment 39

16 years ago
I can't comment for NT, but in Win98SE this is no longer a problem. The icon is
now the red lizard head and the blue triangle. I did have some problems getting
this new icon to stick, but recreating my shortcuts got around that (and I
figure it was a Windows problem).

I'm going to mark this fixed. Feel free to reopen if other Windows varieties are
still broken.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 40

16 years ago
*** Bug 162844 has been marked as a duplicate of this bug. ***
Keywords: verifyme
QA Contact: sairuh → nobody

Comment 41

16 years ago
*** Bug 189844 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.