Menu item in menu bar drawing bug

VERIFIED DUPLICATE of bug 13334

Status

()

Core
XUL
P3
major
VERIFIED DUPLICATE of bug 13334
18 years ago
9 years ago

People

(Reporter: Syd Logan, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Easy to reproduce on Linux, maybe less easy or not possible on NT (haven't
tried).

Start mozilla
Click on a menu item in the menu bar (e.g., File). Without moving the mouse,
click again (this should dismiss the menu), and then again, without moving the
mouse, click again to bring up the menu. The menu will display, but the menu
item in the menu bar (e.g., File) does not redraw to indicate the menu has been
posted. Slight movement of the mouse will cause it to draw (because, I suppose,
a redraw event is posted in response to the mouse movement).

I will attach a gif showing how this looks
(Reporter)

Comment 1

18 years ago
Created attachment 5004 [details]
Image of buggy menu bar

Comment 2

18 years ago
This happens on WinNT just like on Linux, one (possibly) usefull detail:
Waiting for more than about a second after dismissing the menu before bringing
it up again does display the menu item, so this might be a timing/event issue.
(Reporter)

Comment 3

18 years ago
Added some cc's.

Timing, hmmmm.
(Assignee)

Comment 4

18 years ago


*** This bug has been marked as a duplicate of 13334 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
verif.
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: bugzilla → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.