Poor browser performance with Flash embed set to use wmode

RESOLVED DUPLICATE of bug 341380

Status

()

defect
RESOLVED DUPLICATE of bug 341380
15 years ago
12 years ago

People

(Reporter: etraversa, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041101 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041101 Firefox/0.9.1+

In this test case i embed a heavy flash file (161k) with lots of things in
motion at the same time to demonstrate the different cpu outputs I keep getting.   

On Internet Explorer I obtain a cpu output of between 57-63%
On Mozilla and Firefox the cpu is at 100% constant.  

If wmode is not used, then the browsers are identical in performance, setting
wmode causes the problem to appear.  

I'm on Pentium 4, 2.53, with 512 megs of ram.


Reproducible: Always
Steps to Reproduce:
1.Set a flash movie to wmode="transparent" or wmode="opaque"
2.
3.

Actual Results:  
CPU peaked at 100% on moz

Expected Results:  
Be comparable to Internet Explorer In performance

Comment 1

15 years ago
yes it's true, some consideration

explorer-transparent: 60-70%
firefox-transparent: 100%

explorer-opaque: 65-75%
firefox-opaque: 60-70%
Note that the flash binaries used by IE and Firefox are different... this could
well be an issue in the flash binaries themselves.

Comment 3

14 years ago
I've seen this behavior on tons of websites, especially with those annoying
animated Flash ads. Sometimes it's so bad I have to disable Flash to even
attempt to browse the site because the CPU is pegged at 100%. Since IE also has
issues, just not as bad, I'd guess this is a half Firefox/half Flash plugin problem.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 5

14 years ago
This problem is still there as of 1.5 beta 1.
URL is gone, but duping based on comment 0 which mentions opaque
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 233533
wrong dupe
Duplicate of bug: 341380

Updated

12 years ago
Blocks: 289198

Updated

12 years ago
No longer blocks: 289198
You need to log in before you can comment on or make changes to this bug.