Drag and drop a message group fails

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
--
enhancement
RESOLVED WORKSFORME
14 years ago
8 years ago

People

(Reporter: Mattias Holmlund, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

Dragging an entire group of messages to another folder moves just one message
and leaves the display of the remaining messages corrupted.

Reproducible: Always
Steps to Reproduce:
1. Sort messages by sender
2. Group messages by pressing "g"
3. Click on a sender name for a group with more than one message and drag the
group to a different folder

Actual Results:  
One message was moved to the new folder and the message list showed a single
message with no group-header instead of the old group header.

I think that one message disappeared the first time I noticed this bug (i.e. it
can neither be found in the original folder nor in the folder I dragged it to),
but I'm not 100% sure. But this might be a dataloss bug.


Expected Results:  
All the messages from that sender should be moved to the new folder.

Tested with Thunderbird 0.9.

Comment 1

14 years ago
*** Bug 273779 has been marked as a duplicate of this bug. ***

Comment 2

14 years ago
The UI is confusing here; if you drag the group heading, it does something, but 
not the expected thing.  (And the appearance of the behavior is the same whether 
the group is expanded or collapsed.)

If the intent is to not allow dragging the entire group (preferring, as in the 
case of a collapsed thread, to require expanding the thread and selecting all 
messages in order to drag) then dragging should be disallowed on the group 
header.

I am not seeing the display corruption.  As with the original report, I thought 
I saw a message disappear, but on examining the mbox file of the source folder, 
all messages are accounted for in the UI -- the message may have been 
inadvertantly cleared from the list, but I can't reproduce this now.

When using Grouped by Date (Ascending), I did see the "Yesterday" header change 
to "Old mail" but this self-corrected when the folder was re-selected.  This may 
be what the dupe's reporter meant by "now the group name is changed to second 
mail's text."

Reproduced with TB 1.0, Win2K.
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: front-end

Updated

10 years ago
Duplicate of this bug: 423160

Comment 4

10 years ago
see this with current trunk
Assignee: mscott → nobody
Severity: major → minor

Comment 5

10 years ago
xref bug 214111 is suppose

Updated

10 years ago
Depends on: 214111

Comment 6

9 years ago
if this isn't fixed by bug 448288, perhaps some elements of it could be adapted to address this.
Severity: minor → enhancement
Component: Mail Window Front End → Folder and Message Lists
No longer depends on: 214111
QA Contact: front-end → folders-message-lists
(Reporter)

Comment 7

8 years ago
This bug is fixed for me in Thunderbird 3.0.2pre (from Ubuntu ubuntu-mozilla-daily/ppa, package version 3.0.2~hg20100202r4670+nobinonly-0ubuntu1~umd1~karmic). If I drag the group header with the group collapsed, all messages in the group are moved. If the group is expanded, it is not possible to drag the group header, which makes sense.
(Reporter)

Comment 8

8 years ago
Resolving per instructions from Wayne Mery.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.