Download manager duplicates files previously downloaded with similar names

RESOLVED DUPLICATE of bug 231048

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 231048
13 years ago
10 years ago

People

(Reporter: Juan Rey, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.7.3) Gecko/20041027 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.7.3) Gecko/20041027 Firefox/1.0RC1

I have realized that Firefox download manager uses cached files corresponding to
similar URL instead of downloading real files.
http://www.babylonsounds.com/sunbird/sunbird_2004-11-01.zip
http://www.babylonsounds.com/sunbird/sunbird_2004-11-02.zip (does not exist)
(Maybe it gets confused by numbers in the name, thinkig it was saved yet ?)

Some times download a file and save it twice with diferent names. (i.e.
gaim-1.0.2.exe was also saved as gaim-2.0.2.exe )

Reproducible: Always
Steps to Reproduce:
1.Download http://www.babylonsounds.com/sunbird/sunbird_2004-11-01.zip
2.Try to download http://www.babylonsounds.com/sunbird/sunbird_2004-11-02.zip
and http://www.babylonsounds.com/sunbird/sunbird_2004-11-03.zip (inexistent files)

Actual Results:  
Identical file is saved with 3 diferent names
Sunbird_2004-11-01.zip
Sunbird_2004-11-2.zip
Sunbird_2004-11-3.zip

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 231048 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.