Status

RESOLVED WONTFIX
14 years ago
4 years ago

People

(Reporter: michal.ceresna, Assigned: zack)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040917 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040917 Firefox/0.9.3

the attached patch adds support for splashscreen on mozilla start

Reproducible: Always
Steps to Reproduce:
run dits/bin/mozilla -splash

or copy splash.xpm into /dist/bin/mozilla
(Reporter)

Comment 1

14 years ago
Created attachment 164540 [details] [diff] [review]
splashscreen
*** Bug 267622 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
this would be a duplicate of bug 194745....
(Reporter)

Comment 4

14 years ago
Created attachment 165123 [details] [diff] [review]
added else in Makefile.in
(Reporter)

Updated

14 years ago
Attachment #164540 - Attachment is obsolete: true
(Assignee)

Comment 5

14 years ago
Thanks for the great patches. Since they depend on some build system changes,
I'll commit them as soon as the tree is open again. 
bsmedberg, could you double check the build part?
Status: NEW → ASSIGNED

Comment 6

14 years ago
Comment on attachment 165123 [details] [diff] [review]
added else in Makefile.in

>+++ mozilla-cvs/mozilla/xpfe/bootstrap/Makefile.in	2004-11-02 11:00:47.000000000 -0500

>@@ -261,8 +270,13 @@
> ifeq ($(MOZ_WIDGET_TOOLKIT),gtk2)
> ICON_DIR=gtk
> else
>+ifeq ($(MOZ_WIDGET_TOOLKIT),qt)
>+#reuse the gtk icons
>+ICON_DIR=gtk
>+else
> ICON_DIR=$(MOZ_WIDGET_TOOLKIT)
> endif
>+endif

This could be more readable: ifneq (,$(filter gtk2 qt,$(MOZ_WIDGET_TOOLKIT)))

Can I just suggest that splash screens suck? I'm not going to strenuously
object here, but the new toolkit isn't going to support them; they're a pain,
and the ones we provide look awful.

--BDS
QA Contact: cbiesinger → ports-qt
Product: Core → Core Graveyard

Updated

10 years ago
Duplicate of this bug: 194745
This bug has been buried in the graveyard and has not been updated in over 5 years. It is probably safe to assume that it will never be fixed, so resolving as WONTFIX.

[Mass-change filter: graveyard-wontfix-2014-09-24]
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.