External links open in the most recent window even if it is a popup window

VERIFIED DUPLICATE of bug 243893

Status

()

Firefox
Tabbed Browser
--
enhancement
VERIFIED DUPLICATE of bug 243893
14 years ago
9 years ago

People

(Reporter: Pavel Penaz, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

Just to pinpoint one additional downside of bug <a
href-https://bugzilla.mozilla.org/show_bug.cgi?id=243893>243893</a>, this is
what happened to me a few minutes ago. I was playing a Java game, which opens in
a popup. Halfway through the game I received an email and I clicked on a link in
that email. This link  opened in the popup window (since it was the most active
window) as a new tab, effectively hiding the other tab with the game.

This bug is about changing FF behaviour when users have external links set to
open in tabs and popup windows set to not open in tabs.


Reproducible: Always
Steps to Reproduce:
1. Open any webpage with a popup
2. Click on the popup windows to give it focus
3. Now click on a link in an external application
Actual Results:  
The external link opens in tab in the popup window, effectively hiding content
of the popup. (Only way to display previous tab is to use CTRL-TAB)

Expected Results:  
My suggestion is that the external link should be opened in tab in the most
recent normal Firefox window, not in a popup window.

Updated

14 years ago
Version: unspecified → 1.0 Branch

Updated

14 years ago
Component: General → OS Integration

Comment 1

14 years ago
see also bug #143866
I have also stumbled on this today, using FF1.0.
This is bad, from a user perspective, because he can't get back the previous
content of the popup (wich might be important and irreproducible) without using
a keyboard shortcut. I suppose the same would happen if the user elects to open
external link in 'the most recent tab/window'. So, there are two approaches:
handle popup chromeless windows as 'special' windows, wich never open new tabs
or external links;
or
handle those popup windows as something that the user can revert to a normal
window, that is, restore the full menus and tab bar. I vote for user having
control, i.e, beeing able to revert to a normal window as he sees fit.

I think I will take a look at this, and try to put up a patch.
(Reporter)

Comment 2

14 years ago
Today I found another obtrusive consequence of this bug. External windows also
open in the print-preview window when external links are set to pen in tabs (of
course only if print-preview is the most recent Firefox window). Really confusing..

Comment 3

14 years ago
(In reply to comment #2)
> Today I found another obtrusive consequence of this bug. External windows also
> open in the print-preview window when external links are set to pen in tabs (of
> course only if print-preview is the most recent Firefox window). Really
confusing..

What's more, when the user has multiple tabs open, and then an external link is
targeted to the print preview window, ALL open tabs are attached to the print
preview window; if the user then dismisses the print preview window, the browser
exits, without any confirmation from the user.

This seems to indicate something 's very WRONG with the print preview window!

Please, could someone look at this bug? Should it be filled under tab-browser
component?
I've searched as broadly as possible for a while for a duplicate of this (either
in Fx or Core) and can't find one.  It affects Mac OS X as well as Win (worse in
Win because the menubar is in the window and thus goes missing in this case), so
changing hardware and OS to All and confirming.

I think this belongs to Core:Tabbed Browser rather than Firefox:OS Integration,
so changing that, too.  (Apologies if I've misunderstood where the code for this
resides.)
Assignee: firefox → tabbed-browser
Status: UNCONFIRMED → NEW
Component: OS Integration → Tabbed Browser
Ever confirmed: true
OS: Windows 2000 → All
Product: Firefox → Core
QA Contact: firefox.general
Hardware: PC → All
(Reporter)

Comment 5

14 years ago
Version -> Trunk

Should this bug be labeled as Aviary-Landing?
Version: 1.0 Branch → Trunk
According to what I've been told, external apps opening in crippled tabs bugs
are also supposed to be duped to Firefox bug 243893 (related Core/SeaMonkey bug
is bug 143866).

Moving back to Firefox and resolving as a dupe of bug 243893.

*** This bug has been marked as a duplicate of 243893 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Component: Tabbed Browser → Tabbed Browser
Product: Core → Firefox
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Comment 7

13 years ago
*** Bug 305478 has been marked as a duplicate of this bug. ***
QA Contact: tabbed.browser
You need to log in before you can comment on or make changes to this bug.