Firefox doesn't save style information from imported sheets

VERIFIED DUPLICATE of bug 126309

Status

()

--
major
VERIFIED DUPLICATE of bug 126309
14 years ago
14 years ago

People

(Reporter: david, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)
Build Identifier: Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+rv:1.7.3)+Gecko/20040913+Firefox/0.10

Go to http://www.alistapart.com and then save the page to disk

Reopen the saved file, and you'll notice an extensive amount of style sheet 
information is lost as it wasn't saved

This is because a lot of the stylesheets are called with the @import directive

(Remind me again... but does Firefox also save external files called by 
stylesheets anyway? such as the <code>background: url("")</code> property?

Other than grabbing the CSS files and files called by them manually, which can 
take up to 15 minutes, there is no other work-around.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.alistapart.com
2. Go File > Save Page As > Save in any arbitary location
3. Reopen the saved file
4. Spot the difference
Actual Results:  
Stylesheet information called by the @import directive was missing

Expected Results:  
Saved the @imported sheets along with the <link rel="stylesheet"/> sheets, as 
well as any content called by said stylesheets, such as, but not limited to, 
background images.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 126309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.