Request: groups (when "group by sort") should have the number of read and unread emails

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
14 years ago
11 years ago

People

(Reporter: maa_public, Assigned: mscott)

Tracking

unspecified
Thunderbird2.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 7.53  [en]
Build Identifier: 

It would be nice to have the number of unread and also probably total emails in 
a group name, when emails are grouped by sort.



Reproducible: Always
Steps to Reproduce:
1. Switch to Inbox, choose sort by date, then group by sort. 
2. Look at group names
Actual Results:  
Seen names are:
"Today"
"Yesterday"
"Last Week"
etc.

Expected Results:  
It would be nice to have something like "Today (1)" (when 1 today email is 
unread). When the number of unread is not 0, it could be in bold font for 
consistency with the "Folders" style.
Even more nice it would be to have something like "Today (1 of 20)", where 1 is 
the number of unread today emails and 20 is total number of today emails.

Comment 1

14 years ago
you can use the total and unread columns to get that information...
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> you can use the total and unread columns to get that information...
It wastes space for thousands of emails and used only for a dozen of groups.

My suggestion if for group row to be slightly higher (at least in "closed" 
state) than an email row. If it is higher, much more useful information could be 
placed on it (number of unread/total emails, size of emails, number of work/
todo/personal/etc emails if any, number of flagged/spam emails if any, etc). An 
if a group row is higher, it helps in distinguishing it from a email.

Comment 3

14 years ago
It would also be nice to make the Heading BOLD Only when there is unread mail
instead of all the time.  Just like in Outlook.  That way a user does not need
to expand the headings to see unread email, they can go down the list.
(Assignee)

Comment 4

14 years ago
does outlook show the unread counts for a particular group in the group row?
someone want to post a screen shot if so?

Comment 5

14 years ago
Outlook does display:   the format (# Unread,# Read) in the heading.  I do not
have Outlook on this computer.  I want to say that the headings are very similar
though.  If Unread is >0 then the entire heading is BOLD, otherwise it is Regular.

Comment 6

14 years ago
By heading I'm talking about "+  Name   (Unread,Read)"

Comment 7

14 years ago
Created attachment 191345 [details] [diff] [review]
Code patch

Code to add this feature.  Adds totals to the group header in the format "
(unread/total)" - see the screenshot for what it looks like.

Comment 8

14 years ago
Created attachment 191348 [details]
Screenshot of patch
(Assignee)

Comment 9

14 years ago
I like this idea a lot. 

Some other options:

1) Just show the unread message counts like we do in the folder pane:

Today (5)
Yesterday
Last Week (3)

not displaying anything if there are no unread messages

2) Skipping the unread message count if its value is zero
i.e. instead of 
Today (0/10)
it could be
Today (10)
Yesterday (4/50)

Likewise, if a group has 0 messages in it, we'd show nothing at all:
Today

Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Thunderbird1.1
(Assignee)

Comment 10

14 years ago
opions on the current screen shot vs. option 1 vs. option 2 listed above?

Comment 11

14 years ago
I prefer #2

Comment 12

14 years ago
and if we do that, we might want to automatically hide and restore the thread
total columns (though we don't do that for flat sort either...)
(Assignee)

Comment 13

14 years ago
Created attachment 192746 [details] [diff] [review]
don't show the unread count if there aren't any unread messages

Here's a variation of the contributed fix which skips the unread and the '/' if
the group doesn't have any unread messages.

I'd like to try this out on the trunk to see how folks like it.
Attachment #191345 - Attachment is obsolete: true
Attachment #192746 - Flags: superreview?(bienvenu)

Updated

14 years ago
Attachment #192746 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 14

14 years ago
this is now in the trunk so we can try it out
(Assignee)

Comment 15

14 years ago
someone on mozillazine suggested a 3rd alternative.


Just show the unread counts for the group. 

If Today has 2 unread messages, yesterday has none, you'd see something like:

Inbox (2)
  Today (2)
  Yesterday

I think I like that idea.
(Assignee)

Comment 16

13 years ago
we'll probably leave this alone for 1.5. It's getting late in the game and I'm
not sure which of the ideas I like yet either. 
Target Milestone: Thunderbird1.1 → Thunderbird2.0

Comment 17

13 years ago
Created attachment 202587 [details] [diff] [review]
Only show unread message count

This is another variation of the contributed fix that only shows unread messages (as suggested in Scott's option #1). Of course, if there are no unread messages it doesn't change the group header at all.

--bsiegel

Updated

13 years ago
Attachment #202587 - Attachment is obsolete: true

Comment 18

13 years ago
Created attachment 202750 [details] [diff] [review]
Only show unread message count (FIXED)

Old patch was generating an error after successfully applying. Fixed.
While you are at it, Group By Sort headings should also include size of messages (sum of sizes for that header).
Is there any reason to leave this bug open?  Is the patch in attachment 202750 [details] [diff] [review] something that is (still?) needed?

Comment 21

12 years ago
It would be really good to have a feature like this. One person I know will not change to Thunderbird until it has the same type of feature as Outlook.
Outlook makes the group BOLD if any unread messages and Regular if zero.
This with the option to view the number of unread messages in a column I would think would keep most people happy.
Please add this
Chris

Comment 22

12 years ago
I agree - any reason not to land this, Scott? Are you still on the fence?

Comment 23

12 years ago
For consistency I think it would look better if it worked the way Folders work. i.e. bold if unread mail in folder and (nn) after the folder name where nn is number unread

Comment 24

12 years ago
I have a user who will not move to Thunderbird until this facility is available. They work with there inbox Grouped by Sender and they need to see how many unread emails there are for each person.
What is the status of this improvement?
QA Contact: front-end

Comment 25

11 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1a2pre) Gecko/20080814031842 Shredder/3.0b1pre
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.