indicate that a closed group has any unread messages, should not be bold if all are read (usability issue)

RESOLVED FIXED in Thunderbird 43.0

Status

Thunderbird
Folder and Message Lists
--
enhancement
RESOLVED FIXED
13 years ago
a year ago

People

(Reporter: Alexander Myodov, Assigned: alta88)

Tracking

({polish})

unspecified
Thunderbird 43.0
polish

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Opera 7.53  [en]
Build Identifier: Mozilla Thunderbird 0.9 (20041103)

See "steps to reproduce" and "expected results".

Reproducible: Always
Steps to Reproduce:
1. Switch to Inbox, mark all read.
2. Do sort by date, then group by sort.
3. Open any (say, "today" group). Mark any mail in "today" group unread.
4. Close just opened ("today") group.

Actual Results:  
All groups look similar.

Expected Results:  
The group "today" which contains an unread message should be somehow different 
from other groups.
The most consistent (with "news" case) approach is for a group to be underlined 
when it contains at least one unread email.
Besides, the group can also has a mark in "read" column (see bug 267663, which 
is different nevertheless, cause addresses another issue).
Besides, resolving of bug 267672 could also be useful.
Nevertheless, the most consistent and preferred approach is to have the group 
name underlined.

Comment 1

13 years ago
if you have the unread column displayed, you can tell if a group has unread
messages.

Comment 2

13 years ago
I believe the group heading should be unbold if it only contains unread messages.

The background color can be changed to help identify group headings.
(Reporter)

Comment 3

13 years ago
(In reply to comment #1)
> if you have the unread column displayed, you can tell if a group has unread
> messages.
Yes it's a real workaround to "how to see", but first (and most important) of 
all, it doesn't resolve the inconsistency with style of threads' top email 
(underlined if a thread contains at least one unread email); and second, it's 
too pixel-wasting, having useful information only for group lines (which are 5-
10) but wasting the space for email lines (which number may be several hundreds)
. And at the same time the "read" flag columns is not used for them...

Comment 4

13 years ago
ok, got it, changing summary (since there is a way) and severity to enhancement
Severity: normal → enhancement
Summary: No way to understand when a closed group (when emails are grouped by sort) has unread messages (usability issue) → would like indicator that a closed group has unread messages (usability issue)

Comment 5

13 years ago
*** Bug 274200 has been marked as a duplicate of this bug. ***

Comment 6

13 years ago
this is a real annoyance!

my bug has been mark a dupe of!
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 8

12 years ago
6 comments, and noone confirmed it yet... It would be good if someone with 
sufficient rights confirmed it, otherwise it will be lost.

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
QA Contact: front-end

Comment 9

10 years ago
This issue still exist in TB 2.0.0.0, please confirm. I'd be happy to change usercontent.css, if that offers a solution?

Comment 10

10 years ago
Created attachment 263376 [details]
One of these groups contains an unread message

Here's a screenshot to illustrate the problem. "Yesterday" contains an unread message, but how to tell?

Comment 11

10 years ago
there's a patch in some bug about putting the counts for the groups in the group line, which would give you an indication of what the unread counts are for each group.

You could also use the column picker to add the "unread" column to your thread pane.

Comment 12

10 years ago
Well, that was fast, thanks
I'd misread #1, thinking I had to display the "Read" column, which is on by default, but doesn't show anything useful in the group header

Updated

9 years ago
Assignee: mscott → nobody
seems like this should be easy
Flags: wanted-thunderbird3?
Keywords: polish
Summary: would like indicator that a closed group has unread messages (usability issue) → indicate that a closed group has any unread messages, should not be bold if all are read (usability issue)
Whiteboard: [good first bug]
Component: Mail Window Front End → Folder and Message Lists
QA Contact: front-end → folders-message-lists
Whiteboard: [good first bug]
(Assignee)

Comment 14

2 years ago
Created attachment 8653538 [details] [diff] [review]
groupedUnread.patch


Using the counts to determine unread is ocular carpal tunnel, it should be the well known underline for fast indication.
Attachment #8653538 - Flags: review?(rkent)
(Assignee)

Comment 15

2 years ago
Created attachment 8654612 [details] [diff] [review]
groupedUnread.patch

tweak to only get unread count for collapsed threads.
Assignee: nobody → alta88
Attachment #8653538 - Attachment is obsolete: true
Attachment #8653538 - Flags: review?(rkent)
Attachment #8654612 - Flags: review?(rkent)

Comment 16

2 years ago
Comment on attachment 8654612 [details] [diff] [review]
groupedUnread.patch

Review of attachment 8654612 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8654612 - Flags: review?(rkent) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 17

2 years ago
https://hg.mozilla.org/comm-central/rev/d8297b57fec96d7735db58823e77ed38e9bc4993
Bug 267673 - indicate that a closed group has any unread messages, should not be bold if all are read. r=rkent

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.