Two POP accounts with same server shouldn't use same password

VERIFIED FIXED in M16

Status

MailNews Core
Backend
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: Richard Zach, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I have two POP accounts on the same server.  When I check email on the first, I
get prompted for a password.  When I then check mail on the second server, I do
not get prompted for a password.  Instead, Mozilla sends the password for the
first account.

To reproduce:
1. Set up two pop accounts on the same server, different user IDs, different
passwords
2. Download messages from the first one
3. Download messages from the second

Actual result: Mozilla sends same password for both accounts
Expected result: Mozilla should prompt for password per ACCOUNT, not per SERVER.

Linux build 2000.02.06.09
(Reporter)

Comment 1

18 years ago
Just noticed: when I Get Msg on the second account first, I get prompted for
"Enter password for account1@server".

Comment 2

18 years ago
Reassign to sspitzer, cc jefft and morse. Guys, is this a side effect of the
"stripped vs. unstripped" API for single sign on?
Assignee: phil → sspitzer

Comment 3

18 years ago
No, I don't think this has anything to do with the stripped versus unstripped 
API.  But I would like a little clarification from the reporter.

1. Have you previously told single-signon to save any of your mail passwords 
(i.e., had the checkbox checked when you entered your password)?  You can verify 
this by using the signon viewer.

2. You said that when you check email on the first server, you are getting 
prompted for a password.  Is that prompt asking for your e-mail password or for 
the master password to unlock the data base.  If the latter, then this is 
normal -- you unlock the database once and then the different passwords for the 
two accounts are sent transparently to the server each time you switch from one 
account to the other.

3. You didn't specify whether you were able to get messages from the second 
account even though you weren't asked for a password prompt.  If you indeed were 
able to get the messages, then this would confirm that single signon 
transparently sent the correct password for each account.
yes, I think this is a side effect of something I did.

accepting.
Status: NEW → ASSIGNED
moving to m15
Target Milestone: M15
(Reporter)

Comment 6

18 years ago
Answers to morse's questions:

1. yes. however, the problems also occur when I turn single signon off.
2. email password
3. I was not able to retrieve messages from the server for the second user. 
Instead, got an invalid password warning and another password dialog.

Updated

18 years ago
QA Contact: lchiang → esther
(Reporter)

Comment 7

18 years ago
*** Bug 30318 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

18 years ago
Release note if not fixed by beta1, as per alecf's comments in bug 30318:
"Multiple accounts on one POP server are not fully supported."
Keywords: relnote

Comment 9

18 years ago
*** Bug 19377 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

18 years ago
*** Bug 30649 has been marked as a duplicate of this bug. ***
moving to m16.
Target Milestone: M15 → M16

Comment 12

18 years ago
*** Bug 35763 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
would like to confirm this bug is reproducable in freebsd, linux, and win32.

Updated

18 years ago
Keywords: nsbeta2

Comment 14

18 years ago
Putting on [nsbeta2+] radar.  
Keywords: relnote
Whiteboard: [nsbeta2+]

Comment 15

18 years ago
*** Bug 38401 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
*** Bug 38195 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17
*SPAM* - adding mostfreq keyword to bugs with loads of DUPEs. Please aid this 
effort by adding this keyword to any bugs with more than 15 DUPEs.

Gerv
Keywords: mostfreq
working on this now, just got two pop accounts on mail.subdimension.com
Target Milestone: M17 → M16
ok, I can reproduce.  debugging / working on a fix now.
fix in hand, seeking review from mscott.

I'll attach the patch here.
Created attachment 9052 [details] [diff] [review]
fix for this bug.  pop url needs to have the username in it.
fix has been reviewed by mscott.

will check in when the tree opens.
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 25

18 years ago
When verifying check all platforms, this happens on win98 and mac too on the 
5-23 builds.

Comment 26

18 years ago
Using build 2000-05-24 on linux this is fixed.  I also tested this by Canceling 
the password of the 2nd pop account to see if it would still get msgs and by 
typing in a bogus password.  All worked as it should.  Waiting for mac and win32 
builds to verify on other platforms.

Comment 27

18 years ago
nice job seth, people report this bug ALL the time as you can see by the dupes
thanks, I feel bad I had this sitting in my bug list so long, and the fix was so
easy.

the "mostfreq" keyword is a big help.

Comment 29

18 years ago
Ninoschka verified this on win nt4.0 and I have verfied this as fixed on Mac 
using builds 2000-05-24.   Note:  I was able to reproduce this with 2 pop 
accounts with different ID's, on the same server and that had the same password 
(our test accounts) so we tested this with those accounts.  Having the same 
password is the only thing that was different from the scenario, but since I was 
able to reproduce with my setup I figured it's OK to test with.  If anyone has 
an issue with that, please comment in bug and I will find accounts with 
different passwords.   Verified
Status: RESOLVED → VERIFIED

Comment 30

15 years ago
See also bug 41929, "can't have multiple accounts with same pop/imap server and
username, even port is different".
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.