views based on Labels always have zero results for IMAP folders (tags)

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Robert Morgan, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20040913 Firefox/0.10

When using an IMAP folder, changing to a view based on a label ("Work" or "Not
Work" from the View menu of the search bar) will always show no messages.

Reproducible: Always
Steps to Reproduce:
1.  Go to an IMAP folder
2.  Assign label, say Work
3.  Go to View - Work.  No messages are displayed.
4.  Create a custom view for Not Work.  No messages are displayed.

Actual Results:  
No messages were displayed.

Expected Results:  
Messages should have been displayed according to the labels assigned.

Comment 1

14 years ago
(In reply to comment #0)
> When using an IMAP folder, changing to a view based on a label ("Work" or "Not
> Work" from the View menu of the search bar) will always show no messages.

I confirm that, most of the time, labels are not displayed when using the mail
view. The message view does not display all labels, but only for specific
situations. I can't find the logic but this behaviour is not regular.

There is the same bug when using virtual folders with IMAP online searches.

Comment 2

14 years ago
Same problem here using TB for Win, checked with 1.0 and both 20050203 
nightlies. When selecting any label based view 0 results are returned. Works 
when messages downloaded for offline use.

Checked with Mozilla Mail 1.7.5., works correctly there.

Comment 3

14 years ago
I have the same problem. If a label is used with the messages and I change the
view option from all to e.g. todo or later, no entry is displayed.

If I change from unread (which works) to todo or later nothing happens the
display shows still the unread messages.

Comment 4

14 years ago
I forgot to add that I'm using version 1.0

Comment 5

14 years ago
A small clarification: changing the view from "All" to one based on a label
returns zero results. Changing from any other view, for example "Unread" or
"Last 5 days", simply does not change the view.

Comment 6

13 years ago
Using version 1.0.2 (20050317) on an imap inbox, message view also returns zero
results for my searches for custom headers. I ran into this problem when trying
to sort out mailing lists by their "List-Id" headers. It seems that filters work
fine for these custom headers, but not message view.

Comment 7

13 years ago
I see this bug too - it seems to have been around for a while, but is
reproducible intermittently.

Currently reproducible on TB 1.0.6 on WinXP

Comment 8

13 years ago
(In reply to comment #7)
> I see this bug too - it seems to have been around for a while, but is
> reproducible intermittently.
> 
> Currently reproducible on TB 1.0.6 on WinXP

Also reproduced in the Thunderbird 2005-07-26 nightly from
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/2005-07-26-09-trunk/thunderbird-1.0+.en-US.win32.zip

Comment 9

13 years ago
Same here. This bug makes all lable functionalities useless. It should be 
changed to a major bug since there is no workground.

Comment 10

13 years ago
(In reply to comment #9)
> Same here. This bug makes all lable functionalities useless. It should be 
> changed to a major bug since there is no workground.

Hear hear!

Comment 11

13 years ago
*** Bug 287430 has been marked as a duplicate of this bug. ***

Comment 12

13 years ago
(In reply to comment #10)
> (In reply to comment #9)
> > Same here. This bug makes all lable functionalities useless. It should be 
> > changed to a major bug since there is no workground.
> Hear hear!

I totally agree, can we sort this out?

Comment 13

13 years ago
*** Bug 272834 has been marked as a duplicate of this bug. ***

Comment 14

13 years ago
Views in Thunderbird version 1.5 (20051201) are unable to match custom headers in IMAP folders. The same views work correctly on local folders. IMAP targets are Exchange 2003 & Exchange 5.5.

Comment 15

12 years ago
Seeing similar but not quite identical behaviour: TB 1.5.0.4 and IMAP server. 

Steps:
1. Label some messages with various labels
2. Create saved search which searches all folders for those labels
3. Click on saved search folder: messages displayed as expected
4. Come back to saved folder later (possibly after TB restart): no messages listed
5. In "View" combo, select one label only: messages appear as expected
6. In "View" combo, select all: all messages appear as selected

Comment 16

12 years ago
(In reply to comment #15)
> 6. In "View" combo, select all: all messages appear as selected

Sorry, typo, should be: "all messages appear as expected".

Comment 17

12 years ago
Is this still an issue now that tags have replaced labels?

Updated

12 years ago
Blocks: 201500

Comment 18

12 years ago
For me it works now.
QA Contact: front-end

Updated

10 years ago
Assignee: mscott → nobody

Comment 19

10 years ago
=> WFM per comment 18

please comment if you see otherwise with a current version
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Summary: views based on Labels always have zero results for IMAP folders → views based on Labels always have zero results for IMAP folders (tags)

Comment 20

10 years ago
Confirmed that this is fixed (using 2.0.0.19)
You need to log in before you can comment on or make changes to this bug.