Java plugin place-holder does not find Java plugin, plugin information bar works

VERIFIED FIXED

Status

Toolkit Graveyard
Plugin Finder Service
--
major
VERIFIED FIXED
14 years ago
4 years ago

People

(Reporter: Pavel Penaz, Assigned: Doron Rosenberg (IBM))

Tracking

({fixed-aviary1.0, testcase})

1.7 Branch
x86
Windows XP
fixed-aviary1.0, testcase

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

This happened to me on page http://hry.atlas.cz/hra_stoly.jsp?typHry=5. It is
strange that when I click "Find missing plugins" on the plugin information bar,
Firefox finds the Java plugin just fine. But when I click on the plugin
placeholder, Firefox does not find anything.

Reproducible: Always
Steps to Reproduce:
1. you must not have Java installed
2. click on the testcase
3. click on the Java plugin place-holder

Actual Results:  
Plugin finder does not find any plugin..

Expected Results:  
Plugin finder finds Java plugin..
(Reporter)

Comment 1

14 years ago
Created attachment 164588 [details]
testcase - click on the plugin place-holder..

To reproduce this, you must not have Java plugin installed..
(Reporter)

Updated

14 years ago
Attachment #164588 - Attachment description: click on the plugin place-holder.. → testcase - click on the plugin place-holder..
(Reporter)

Updated

14 years ago
Keywords: testcase
Version: unspecified → 1.0 Branch
(Reporter)

Updated

14 years ago
Summary: Java plugin place-holder does not find Java plugin, plugin information bar work → Java plugin place-holder does not find Java plugin, plugin information bar works

Comment 2

14 years ago
Duplicated with testcase on winXPSP2

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103
Firefox/1.0RC2
(Reporter)

Comment 3

14 years ago
The same behaviour on page: http://www.dslreports.com/tweaks

Since Java plugin is so widely used --> nominating blocking-aviary1.0?
Flags: blocking-aviary1.0?

Comment 4

14 years ago
I can reproduce this with today's winXP build. Works from the information bar,
fails from the puzzle piece.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 164796 [details] [diff] [review]
Make the installSinglePlugin() logic the same as in newMissingPlugin() (clicking puzzle piece vs clicking the button in our UI).
Comment on attachment 164796 [details] [diff] [review]
Make the installSinglePlugin() logic the same as in newMissingPlugin() (clicking puzzle piece vs clicking the button in our UI).

r+sr=ben@mozilla.org
Attachment #164796 - Flags: superreview+
Attachment #164796 - Flags: review+

Updated

14 years ago
Attachment #164796 - Flags: approval-aviary?

Comment 7

14 years ago
Comment on attachment 164796 [details] [diff] [review]
Make the installSinglePlugin() logic the same as in newMissingPlugin() (clicking puzzle piece vs clicking the button in our UI).

a=asa for aviary checkin.
Attachment #164796 - Flags: approval-aviary? → approval-aviary+
Fixed on the aviary branch.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
(Reporter)

Comment 9

14 years ago
--> Verified

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041106 Firefox/1.0
Status: RESOLVED → VERIFIED

Updated

14 years ago
Flags: blocking-aviary1.0?
Product: Firefox → Toolkit

Comment 10

7 years ago
I do not understand why this is marked fixed. On Windows 7 FF cannot fine Java plugin with Java present, installed, and otherwise in daily use without any issue. Furthermore, it cannot find the download place of the plugin automatically and later on even after installing the plugin FF would not find it.

I am using web pages with Java on Win XP only.
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.