IMAP subscribed folders forget "Check this folder for new messages" setting when Thunderbird quits

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5 (KHTML, like Gecko) Safari/125.9
Build Identifier: 

When Thunderbird starts, I have to manually check "Check this folder for new messages" for all 
subscribed folders (not the Inbox). The setting is remembered until I quit Thunderbird. When 
Thunderbird is restarted, the subscribed folders are not checked for new mail, and the "Check this 
folder for new messages" boxes are all unchecked.

Reproducible: Always
Steps to Reproduce:
1. choose "Properties" for a subscribed IMAP folder
2. check "Check this folder for new messages"
3. quit Thunderbird
4. start Thunderbird
5. choose "Properties" for a subscribed IMAP folder
6. "Check this folder for new messages" is unchecked
Actual Results:  
"Check this folder for new messages" is unchecked. The subscribed IMAP folders are not 
automatically checked for new mail.

Expected Results:  
"Check this folder for new messages" should be checked when Thunderbird is restarted, i.e., it should 
remember the setting from before it was quit.

I have not encountered this problem using Thunderbird in Windows XP.

Comment 1

14 years ago
This is not just a Mac issue, I see it under Windows too.  I see this as a
critical bug as it makes IMAP accounts close to unusable.  I keep many different
folders and it is a pain to have to click manually on each one to see if there
is mail in it.  This makes Thunderbird unacceptable for my needs and I plan to
switch to a different client until this gets fixed.

Comment 2

13 years ago
I do not see this bug in Windows on build 2005090406.  Thunderbird was not
checking for new mail in non-INBOX folders until I right-clicked on each one,
and selected to "Check this folder for new mail".  This of course is a (slightly
hidden) feature, not a bug.
(Reporter)

Comment 3

13 years ago
Agreed, but if you have to manually select "Check this folder for new mail" each
time you start Thunderbird (as was the case), that's a bug. I think the solution
I eventually found was to "Subscribe" to the folders I always wanted checked.

If you have to "Subscribe" in order for the folders to be checked, I wonder what
the "Check this folder for new mail" setting actually does.

Comment 4

13 years ago
At least in Mozilla 1.7.11, subscribing does not affect the "check for new messages" setting.  While not enough to make me stop using Mozilla quite, this is a seriously annoying bug.  It would be much less annoying if there was a simple way to say "check all subscribed folders" and not have to manually check the dozens of folders I have.

Comment 5

13 years ago
Can confirm this behavior on 1.5 Beta 2 (Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Thunderbird/1.5 ID:2005102519)

Checking the "check for new messages" button seems to work in this build. Thunderbird does remember to check between instances of the program, it is not forgetting. However if I have subscribed to these folders I shouldn't have to manually check the box in the folder properties for it to remember.

Is Bug 288699 a duplicate of this bug?

Bug 314021 might also be a duplicate.

Comment 6

12 years ago
I'm seeing this behavior in 1.5.0.4 on my Mac.
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

And boy is it bad.

I sure would like it if setting that property for the containing folder would have it *set* it for each subfolder, so that I could go and unset the few thunderbird doesn't need to check.

Comment 7

12 years ago
Ahem. The actual version string from thunderbird:
version 1.5.0.4 (20060516)

;-)
QA Contact: general

Comment 8

12 years ago
This is a REALLY annoying bug!!  
I am using Thunderbird version 2.0.0.0 (20070326) on a Mac Os X 10.4.9.
I have 4Gb of mail in 2000 folders on Groupwise that I am accessing via IMAP and the selection of folders just does not work....via 

Offline Settings --> Select folders for Offline use...

The isues are:
1. You can't select all the folders without manually opening the entire tree. 
2. Then you only seem to be able to select a couple of hundred folders to sync... then after the sync you can select another 300-400 folders.
3. Then some of the folders that have been select randomly unselect themselves for no good reason...this is very annoying
4. During the sync process Thunderbird can freeze if you do to many other things (like check mail) I am not sure if this is an IMAP sync problem or a general stability problem

The problem is so bad I am contemplating ditching Thunderbird (which is otherwise pretty neat).  I have done 2 complete reinstalls and this does seem to have made much difference (also deleting the library files)

Comment 9

12 years ago
This problem also occurs when I "Compact Folders" and the Thunderbird crashes during this process, (which happens pretty easily if you do anything in Thunderbird while it is compacting).  This occurred again and 500 IMAP folders got deslected and 1Gb of mail got removed from my offline store. 

Comment 10

11 years ago
Can anyone confirm this on trunk, on any OS?
I don't see this on trunk version 3.0a1pre (2008041203) vista. 
This and dupes/related bugs have been around too long  
bug 221792
bug 288699
bug 388417
bug 162475
bug 334483 

Ian, have you looked at crash bug 379531, bug 406851, bug 392015, bug 370229 
Assignee: mscott → nobody
Severity: normal → major

Comment 11

10 years ago
Ian writes "Actually I switched to Mac Mail which works (but also has its own issues).  If this folder problem could be sorted I would definitely consider moving back (for off line mail)."

bug 399716 may be another example of this, but can't be confirmed as that reporter is gone also.
This works okay for me. I used it from December 2007 through February 2008. However I got tired of typing my IMAP password (or Master Password) twice every time I started Thunderbird so turned it off. The typing the password twice is a different bug... but I do not see it when searching for it. Could have sworn it was reported already though.
The steps to reproduce WFM... wsmwk and jaym also report WFM from comments 10 and 12 -> RESO WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.