Changing print preview scale does not put page # back to 1

RESOLVED DUPLICATE of bug 205783

Status

()

Firefox
General
--
trivial
RESOLVED DUPLICATE of bug 205783
14 years ago
14 years ago

People

(Reporter: Scott Copus, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

During print preview, if you change the scale (100%, 90%, etc), the print
preview will revert to showing page 1 again... which is OK.

However, if you happen to be viewing page 2 or higher and THEN you change the
scale, the page number (on the toolbar) does NOT revert back to page 1 again...
even though page 1 is always the page that shows up after re-scaling.

Suggestion:  Fix so it goes back to "page 1" on the toolbar... OR "try" to
figure out how to STAY on the preview text... even though the page numbers may
change due to re-scaling.

Feature request:  During print preview, have a "hand" where you can move the
page up or down (like Adobe Reader feel).


Reproducible: Always
Steps to Reproduce:
1.Print Preview a web page longer than "one page".
2.Click the "next page" button to go to page 2, 3, etc.
3.Change the scale to some other value (100%, 90%, etc)
Actual Results:  
Actual: Page 1 appears again, but page index remains at 2, 3, etc.

Expected Results:  
Expected: Page toolbar page number should revert back to "1".

Comment 1

14 years ago
CONFIRMED: Firefox 1.0.1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225
Firefox/1.0.1

RELATED TO: Bug 284541

*** This bug has been marked as a duplicate of 205783 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.