add a splitter to resize the search bar

VERIFIED FIXED in Firefox 3 alpha8

Status

()

Firefox
Toolbars and Customization
--
enhancement
VERIFIED FIXED
13 years ago
7 years ago

People

(Reporter: nrlz, Assigned: Neil Deakin)

Tracking

(Depends on: 1 bug)

Trunk
Firefox 3 alpha8
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Firefox/0.10.1

Using the Texturizer tweak found at
(http://texturizer.net/firefox/tips.html#app_searchbarsize) I resized the search
bar on Firefox. But on MacOSX, the search bar does not look resized. But it
indeed is resized because I can type long sentences in it. (See screenshot)

I also tried various different tweaks to resize the search bar including setting
the flex CSS on "id=searchbar" as well as "id=search-container" and setting
pixel widths too. All to no avail.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Created attachment 164663 [details]
screenshot of Firefox toolbar on Mac
Assignee: p_ch → webmail

Comment 2

13 years ago
I'll consider making the search box flexible in the future, but this isn't a
bug. Marking as an enhancement request.
Severity: normal → enhancement
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Future
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> I'll consider making the search box flexible in the future, but this isn't a
> bug. Marking as an enhancement request.

I don't understand. I've already made the search box flexible with the
texturizer tip. And it is also flexible according to my screenshot.

The problem is that it's *look* does not correspond to it's *feel*. I can type
text beyond it's box boundaries.

Comment 4

13 years ago
As a workaround, the resizesearchbox extension v0.0.4 now supports OS X:

http://dragtotab.mozdev.org/resizesearchbox/

*** This bug has been marked as a duplicate of 228395 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 6

10 years ago
Created attachment 262241 [details] [diff] [review]
simple implementation using a splitter

Looks OK on Mac, but needs a suitable grippy image on other platforms (and a pointer cursor on all). Will leave the styling for now.
 
- adds a splitter to the toolbar whenever the urlbar and searchbar are next to each other (either order).
- persists the size between sessions

Another possibility is to add a fourth type of toolbar spacer which allows dragging, or to just the existing 'separator' type draggable.
Assignee: kevin → enndeakin
Status: RESOLVED → ASSIGNED
Attachment #262241 - Flags: ui-review?(beltzner)
Resolution: DUPLICATE → ---
(Assignee)

Updated

10 years ago
Flags: blocking-firefox3?
Target Milestone: Future → Firefox 3 alpha6
Flags: blocking-firefox3? → blocking-firefox3+

Comment 7

10 years ago
Neil, beltzner: any update on this? This is a P2 on the PRD and blocking-firefox3+.
OS: Mac OS X → All
Hardware: Macintosh → All
Version: unspecified → Trunk
Comment on attachment 262241 [details] [diff] [review]
simple implementation using a splitter

I like the effect of this (though mconnor notes over IRC that there's apparently problems with the persisting width between sessions) but think the ultimate implementation would be to create a splitter XUL element which can be added to the palette as you suggest, and then add that to the default UI. Seems cleaner than just always checking for these two elements.
Attachment #262241 - Flags: ui-review?(beltzner) → ui-review+

Updated

10 years ago
Target Milestone: Firefox 3 alpha6 → Firefox 3 beta1
(Assignee)

Comment 9

10 years ago
(In reply to comment #8)the
> the ultimate implementation would be to create a splitter XUL element which
> can be added to the palette as you suggest, and then add that to the default UI. 
> Seems cleaner than just always checking for these two elements.

True, but the urlbar and searchbar are the only resizable items. If an extension adds others, having a customizable item becomes tricky because the width has to be persisted on each item.

(Assignee)

Comment 10

10 years ago
Created attachment 270333 [details] [diff] [review]
add a splitter to customize dialog

This patch adds a splitter (Resizer) to the customize dialog, but it doesn't include it in the toolbar by default.

It looks good on Mac, and is just a tall vertical bar on other platforms. We will probably want to tweak the css a bit to make it look better, but
Attachment #262241 - Attachment is obsolete: true
Attachment #270333 - Flags: review?(mano)
Comment on attachment 270333 [details] [diff] [review]
add a splitter to customize dialog

I would really r- some hunks here if they were note in the context of, but.

r=mano, please add the missing \n to customizeToolbar.properties.
Attachment #270333 - Flags: review?(mano) → review+
/were not/
(Assignee)

Updated

10 years ago
Attachment #270333 - Flags: ui-review?(beltzner)

Comment 13

10 years ago
Do we really need a new ui-r request here? Beltzner already gave a ui-r+.
(Assignee)

Comment 14

10 years ago
The latest patch and the patch before it don't implement this using the same UI.

Updated

10 years ago
Whiteboard: [need ui-review beltzner]
Comment on attachment 270333 [details] [diff] [review]
add a splitter to customize dialog

Please add it to the default toolbar as well. For styling, what do you need? A PNG?
Attachment #270333 - Flags: ui-review?(beltzner) → ui-review+
Missing the freeze, moving out.
Target Milestone: Firefox 3 M7 → Firefox 3 M8

Updated

10 years ago
Whiteboard: [need ui-review beltzner] → [checkin needed]

Updated

10 years ago
Keywords: checkin-needed
Whiteboard: [checkin needed]
Keywords: checkin-needed
Whiteboard: [checkin needed]
(Assignee)

Comment 17

10 years ago
Created attachment 274980 [details]
image of windows and mac

(In reply to comment #15)
> (From update of attachment 270333 [details] [diff] [review])
> Please add it to the default toolbar as well. For styling, what do you need? A
> PNG?
> 

beltzner: here is an image of the resizer on Mac and Windows. On Mac, the native theme appearance looks ok. On Windows, the vertical bar doesn't look too great. Suggestions would be to draw a similar dot, or have a vertical bar that doesn't stretch to the edge of the toolbar. Linux is similar to Windows.

Updated

10 years ago
Attachment #274980 - Attachment is patch: false
Attachment #274980 - Attachment mime type: text/plain → image/png
(Assignee)

Updated

10 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]

Updated

10 years ago
Depends on: 391121

Updated

10 years ago
Depends on: 391128

Comment 18

10 years ago
Verified FIXED using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080614 Minefield/3.0a8pre.

Adding in-litmus+ flag: http://litmus.mozilla.org/show_test.cgi?id=4530 and http://litmus.mozilla.org/show_test.cgi?id=4529.
Status: RESOLVED → VERIFIED
Flags: in-litmus+
Depends on: 391293
No longer depends on: 391293

Comment 19

10 years ago
I don't like this UI for resizing the search bar, for three reasons.

(1) In an existing profile, resizing the search bar requires a lot of steps.

1. Open "Customize Toolbars".
2. Drag the tiny "Resizer" item to between the address bar and search bar.
3. Close "Customize Toolbars".
4. Drag the resizer.

I don't think many users would figure that out, given the goal "make the search bar a little bigger".

(2) If I don't want the resizer to be on the toolbar permanently, resizing the search bar once requires adding the resizer and then removing it.  I think I should be able to resize the search bar quickly whenever I'm in Customize Toolbars mode, even if I haven't added a permanent "resizer" element.

(3) If I add the resizer somewhere other than between the address bar and search bar, bizarre things happen (e.g. squished Home button).

Updated

10 years ago
Duplicate of this bug: 205011

Updated

10 years ago
Component: Search → Toolbars
QA Contact: search → toolbars
Summary: resizing search bar works but looks bad → add a splitter to resize the search bar

Comment 21

10 years ago
The solution provided here is buggy.

1) Removing the splitter removes the search bar as well, despite these items being separate in the customise 'pallete'

2) Removing the splitter removes the search bar as well, but also leaves a splitter behind on the far right end of the Navigation Toolbar.

3) The look of the splitter appears completely out of place with the rest of the Firefox UI. This needs to be addressed by the people who developed the current theme. At the moment it looks like developers, not graphic designers, have tacked on this UI element.

Comment 22

10 years ago
1+2) WFM (on existing profile)
3) I agree

Additionally the splitter pretty much causes mayhem when put and drag elsewhere than between search and URL bar (say between Home button and URL bar). The resizer should only affect resizeable elements, in default UI these are fixed and flexible space and URL Bar/search bar. I don't see the point in resizing a flexible space (defies its purpose) and the width of fixed spaces can be increase by simply adding more of them.
I don't see the point in being able to place it other than left or right of the search bar, plus there must be some shrinkable element (e.g. a button wouldn't qualify.)

Should new bugs be opened for these issues?

Comment 23

10 years ago
(In reply to comment #22)
> Should new bugs be opened for these issues?

Yes, please, and mark them as blocking this bug. Making comments in a closed bug accomplishes almost nothing.
Depends on: 393581

Updated

10 years ago
Depends on: 393733, 393735
Depends on: 394022

Updated

10 years ago
Depends on: 394091
No longer depends on: 394022
Depends on: 393718

Updated

10 years ago
Depends on: 398023

Updated

10 years ago
Depends on: 405072
(Assignee)

Updated

10 years ago
No longer depends on: 405072
Depends on: 412601
You need to log in before you can comment on or make changes to this bug.