wendymae.com - WMV files served as text/plain

RESOLVED FIXED

Status

Tech Evangelism
Desktop
RESOLVED FIXED
14 years ago
4 years ago

People

(Reporter: Aaron Slunt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

If you go to the URL above, and try to open it with WMP, or whatever, Firefox
firsts fully downloads the file before opening up a media player to play it.

After seeing a topic about someone being pissed off that they couldn't stream
music, but had to wait for it to fully download, I believe there should be an
option that would allow the user to stream the music and having it play in their
media player. It does make sense to allow this; many people just want to play a
file, and have it be done with, not saving it on their hard drive and then
deleting and blah blah blah.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
(In reply to comment #0)
> ...many people just want to play a
> file, and have it be done with, not saving it on their hard drive and then
> deleting and blah blah blah.

Firefox should be deleting these files automatically if the user chose to play
them. So this should not be a reason for adding this feature. The only reason I
can see for the feature is to be able to see and/or hear the multimedia more
quickly.

This streaming feature is present in Internet Explorer by default and is already
handled in Firefox by the DownloadWith extension http://downloadwith.mozdev.org/
(see Note 6 at http://forums.mozillazine.org/viewtopic.php?t=140828#Notes for a
short explanation of how to configure DownloadWith to stream).
Whiteboard: parity-ie

Updated

14 years ago
Summary: Enhancement: Ability to stream music → Ability to stream music and videos
*** Bug 308601 has been marked as a duplicate of this bug. ***

Comment 3

12 years ago
Having the ability to stream Windows Media files, both audio and video, would be an important feature to have built-in to the browser. Many Firefox users may just click on a link to open up a WMV file and just note the time it takes to begin playing the video, because the entire file has to be downloaded by Firefox before it is sent to the Windows Media Player. Some may go back to using Internet Explorer because it takes only a few seconds to begin playing the video.

As more and more users have access to high-speed connections, video on the Web will become even more prevalent. An inexperienced Firefox user may note that it takes several minutes to begin playing a WMV file with Firefox but only a few seconds to begin playing the same file with IE. Many of these users may not be aware of the existence of the DownloadWith extension. In addition, the DownloadWith extension that is on Mozilla's Web site - https://addons.mozilla.org/firefox/27/ - has last been updated in 2004. It is not compatible with Firefox 1.5 or even 1.0. There is no link on this page to download the modified version that works with Firefox 1.5.

Having the ability to immediately send a WMV file to Windows Media Player instead of having to download the entire file before playing it would be a worthwhile feature to be included with Firefox.
(Reporter)

Comment 4

12 years ago
Is this possibly an issue with the WMP plugin itself, and not firefox?

I'm on Gentoo ~amd64 now, and using mplayer-plug-in, I'm able to stream videos. It's all a matter of telling mplayer how much to cache before it starts playing...

I'm thinking of closing this bug because of that, any thoughts?

Comment 5

12 years ago
When "stub" files are used to reference WMV files (e.g. http://www.wendymae.com/video/car_horn_organ.asx) then the file is properly streamed. However, when accessing the WMV file directly (e.g. http://www.wendymae.com/video/car_horn_organ.wmv), the entire WMV file is downloaded by Firefox before it plays.

No matter how I set Windows Media Player's network buffering, a WMV file still has to be downloaded completely by Firefox before playing. However, when accessing a WMV file directly with Internet Explorer, the file is streamed.

Is it possible to tell Firefox that when it encounters a WMV file, to immediately send it to Windows Media Player instead of downloading the entire file via Firefox and then sending it to the WMP?
Assignee: bross2 → nobody
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
(Reporter)

Comment 6

10 years ago
dalef, are you still having this issue? Still a WFM on Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9) Gecko/2008062219 (Gentoo) Firefox/3.0

Comment 7

10 years ago
(In reply to comment #6)

Yes, I am still having this issue with Firefox 3.0 on Windows XP SP3. When clicking on the link - http://www.wendymae.com/video/car_horn_organ.wmv - the entire Windows Media file is downloaded by Firefox before it begins playing in Windows Media Player.


> dalef, are you still having this issue? Still a WFM on Mozilla/5.0 (X11; U;
> Linux x86_64; en-US; rv:1.9) Gecko/2008062219 (Gentoo) Firefox/3.0
> 

Updated

10 years ago
Assignee: nobody → english-us
Severity: enhancement → normal
Status: UNCONFIRMED → NEW
Component: Plug-ins → English US
Ever confirmed: true
Product: Core → Tech Evangelism
QA Contact: plugins → english-us
Summary: Ability to stream music and videos → wendymae.com - WMV files served as text/plain
Whiteboard: parity-ie

Comment 8

4 years ago
→ http --print hH GET www.wendymae.com/video/car_horn_organ.wmv 'User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0'
GET /video/car_horn_organ.wmv HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Host: www.wendymae.com
User-Agent:  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:31.0) Gecko/20100101 Firefox/31.0

HTTP/1.1 200 OK
Accept-Ranges: bytes
Content-Length: 2449174
Content-Type: video/x-ms-wmv
Date: Tue, 02 Sep 2014 08:37:52 GMT
Last-Modified: Mon, 27 Aug 2007 18:34:48 GMT
Server: Apache


This seems to be fixed.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Component: English US → Desktop
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.