Last Comment Bug 267909 - l10n CVS request: Khmer (km-KH) - Javier SOLA <javier@khmeros.info>
: l10n CVS request: Khmer (km-KH) - Javier SOLA <javier@khmeros.info>
Status: RESOLVED INCOMPLETE
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: All All
: -- normal (vote)
: ---
Assigned To: Marcia Knous [:marcia - use ni]
: Daniel (Leaf) Nunes
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-05 03:37 PST by Javier SOLA
Modified: 2008-03-26 18:13 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
SSH public key for CVS access (738 bytes, text/plain)
2004-11-05 03:40 PST, Javier SOLA
no flags Details

Description Javier SOLA 2004-11-05 03:37:05 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

After finishing the materials for the CVS based localization of Khmer, I would
like to have access in order to commit the files.

The localized files for Firefox 1.0 in Khmer, in CVS structure, are in:
http://www.khmeros.info/firefox/browser-km-KH.zip 
http://www.khmeros.info/firefox/toolkit-km-KH.zip 

The help file for 1.0 is also in 
http://www.khmeros.info/firefox/help.jar

The HTML pages have been sent to Peter and the snippets to MLP@mozilla.org

The agreement form has been signed and faxed.

The SSH public key will be attached to this bug.

I will be the contact person for the Khmer (km-KH) localization team.

Javier SOLA - javier@khmeros.info



Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Javier SOLA 2004-11-05 03:40:27 PST
Created attachment 164715 [details]
SSH public key for CVS access
Comment 2 Javier SOLA 2004-11-05 03:40:50 PST
.
Comment 3 Benjamin Smedberg [:bsmedberg] 2004-11-05 05:05:21 PST
I am not going to have time to review this for simultaneous release with 1.0,
but I'll look at it soon. I'll try to get a volunteer from IRC #l10n to help get
the help files into a CVS format also.
Comment 4 Marcia Knous [:marcia - use ni] 2004-11-10 13:31:52 PST
fax form received.
Comment 5 Zibi Braniecki [:gandalf][:zibi] 2004-11-11 08:17:28 PST
Found issues:

1) mozilla/browser/defines.inc - please, setup your own UUID
2) mozilla/browser/profile/bookmarks.html - "Firefox crew picks" should be removed
3) mozilla/browser/installer/installer.inc - not localized
4) i don't know if there is any standard on this, but this package has Windows
line endings.
5) mozilla/toolkit/defines.inc - is english
6) mozilla/toolkit/installer - is not translated at all. (please do not forget
about charset.mk)
7) mozilla/toolkit/* most of accesskeys and commandkeys are in latin alphabet.
8) mozilla/toolkit/chrome/global-platform/*/intl.properties - ISO-8859-1 ?
9) compare locales:
10) lack of  ./README.txt

Entities in ./chrome/browser/browser.dtd don't match:
    fullScreenMinimize.tooltip
    fullScreenRestore.tooltip
    fullScreenClose.tooltip

Properties in ./chrome/browser-region/region.properties don't match:
    browser.search.order.1
    browser.search.order.2

Entities in ./chrome/global/finddialog.dtd don't match:
    cancelButton.label

no comparison for ./chrome/global/intl.css
no comparison for ./chrome/global-region/builtinURLs.rdf

Entities in ./chrome/global-region/region.dtd don't match:
    locale.dir

Properties in ./chrome/mozapps/downloads/downloads.properties don't match:
    statusFormat

Entities in ./chrome/mozapps/plugins/plugins.dtd don't match:
    pluginWizard.licensePage.title
    pluginWizard.finalPage.moreInfo.label
    pluginWizard.finalPage.restart.label

Properties in ./chrome/mozapps/plugins/plugins.properties don't match:
    pluginInstallationSummary.notAvailable
    pluginInstallation.unknownPlugin
    missingPlugin.label

Entities in ./chrome/mozapps/update/update.dtd don't match:
    resetHomepage.label
    resetHomepage.accesskey

From help:
  ./platformStrings.dtd
  ./tabbed_browsing.xhtml
Comment 6 Zibi Braniecki [:gandalf][:zibi] 2004-11-11 10:32:16 PST
point 4) - ok. i have confirmation from Benjamin. There should be only unix
style line
endings. Please fix it
Comment 7 Zibi Braniecki [:gandalf][:zibi] 2004-11-11 12:45:07 PST
There's a mistake in my review.

Forget about

 Entities in ./chrome/global/finddialog.dtd don't match:
    cancelButton.label

and
Properties in ./chrome/mozapps/downloads/downloads.properties don't match:
    statusFormat
Comment 8 Javier SOLA 2004-11-11 16:54:44 PST
Thanks for all this, but before we continue, we need to know something for which
I have not been able to get an answer.

The only character set for Khmer is Unicode. Is it possible to set charset.mk to
UTF-8 and use Unicode? My impression from comments in the localization list is
that it is not possible for Windows. This is why we have left the installation
process in English.

Can readme.txt be in Unicode? There is alsoa  problem with this, as in Windows
it uses Notepad.exe, which does accept Unicode.. but you have to select the font
by hand, and it definitelly does not have a Khmer font installed by default, so
the readme.txt cannot be read in Khmer, we should probably include it in English.

Also, I believe Mozilla does not accept shortcut keys other than Latin.

intl.css needs to be changed in order to use specific Khmer fonts, otherwise in
Windows it uses standard fonts and it does not work.

We will start working on the other stuff.

Thanks!
Comment 9 Zibi Braniecki [:gandalf][:zibi] 2004-11-11 19:47:38 PST
(In reply to comment #8)
> The only character set for Khmer is Unicode. Is it possible to set charset.mk to
> UTF-8 and use Unicode? My impression from comments in the localization list is
> that it is not possible for Windows. This is why we have left the installation
> process in English.

You mean, there is no Windows CHARSET for Khmer? Lucky ones...
Of course, english is the only choice here :(
 
> Can readme.txt be in Unicode? There is alsoa  problem with this, as in Windows
> it uses Notepad.exe, which does accept Unicode.. but you have to select the font
> by hand, and it definitelly does not have a Khmer font installed by default, so
> the readme.txt cannot be read in Khmer, we should probably include it in English.

Notepad is able to print Unicode in WinXP,2003, 2000 and ME.

> 
> Also, I believe Mozilla does not accept shortcut keys other than Latin.

Hm, that clears the point.
Comment 10 Benjamin Smedberg [:bsmedberg] 2004-11-12 04:35:26 PST
> The only character set for Khmer is Unicode. Is it possible to set charset.mk to
> UTF-8 and use Unicode?

No. Windows sucks. Although we have a plan to unsuckify the installer, probably
after 1.1.

> intl.css needs to be changed in order to use specific Khmer fonts, otherwise in
> Windows it uses standard fonts and it does not work.

This does not sound like a correct solution. The mozilla font-mapping code
should be able to handle any unicode repertoire. cc'ing jshin/smontagu for input
here.
Comment 11 Jungshik Shin 2004-11-12 07:01:57 PST
(In reply to comment #10)
> > The only character set for Khmer is Unicode. Is it possible to set charset.mk to
> > UTF-8 and use Unicode?
 
> No. Windows sucks. Although we have a plan to unsuckify the installer, probably
> after 1.1.

That's because Windows installer uses 'A' APIs extensively, right?

> > intl.css needs to be changed in order to use specific Khmer fonts, otherwise in
> > Windows it uses standard fonts and it does not work.
> 
> This does not sound like a correct solution. The mozilla font-mapping code
> should be able to handle any unicode repertoire. cc'ing jshin/smontagu for input

I'm not sure what's talked about. font-family in intl.css is localizable, isn't
it? If so, why not specify a Khmer font there? Am I missing anything? 


Comment 12 Zibi Braniecki [:gandalf][:zibi] 2005-01-13 07:59:27 PST
I will re-review those files today and check them in.
Comment 13 Zibi Braniecki [:gandalf][:zibi] 2005-02-23 16:45:13 PST
no updates yet. r-
Comment 14 Marcia Knous [:marcia - use ni] 2006-07-03 14:17:32 PDT
Per Comment 13 can this bug be closed?
Comment 15 Axel Hecht [:Pike] 2008-03-26 18:13:28 PDT
This is long gone, resolving INCOMPLETE.

Note You need to log in before you can comment on or make changes to this bug.