If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mouse Cursor 'jumps' on clicking links

RESOLVED EXPIRED

Status

()

Firefox
General
--
major
RESOLVED EXPIRED
13 years ago
12 years ago

People

(Reporter: James Norris, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

When clicking links in Linux builds of firefox, using Mandrake with KDE 3.2 and
custom 2.6 kernel (for ATi graphics drivers, mostly) the mouse cursor will jump
to the right hand side of the link moving about an inch. If the mouse is still
over the link after it's moved, the click will be counted, if not, it won't
(unless the movement moves the cursor over another link, in which case it will
navigate to the new link, not the original one.)

This has happened since I was using 0.7 and has been a problem with all
nightlies I've used and official releases since then. Have tried with clean
profile on latest RC2 build. But still happens. For current build info, see the
included build dates, but only occurs in Linux (as I'm reporting on Windows machine)

Reproducible: Always
Steps to Reproduce:
1.Open a page with hyperlinks or buttons that redirect you to another page.
2.Click the link or button.

Actual Results:  
Mouse cursor 'jumps' about an inch to the right hand side of the link,
sometimes, resulting in the link not activating.

Expected Results:  
Should have navigated to the location suggested by the link and the mouse cursor
should stay still.

Comment 1

13 years ago
When attempting to click on a link, as the left mouse button is clicked the the
cursor will jump away from the link.  Have seen this since .92 using Windows XP.
(Reporter)

Comment 2

13 years ago
Still seeing this on Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a6)
Gecko/20050105 Firefox/1.0+
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
This bug has been automatically resolved after a period of inactivity (see above
comment). If anyone thinks this is incorrect, they should feel free to reopen it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.