Mozilla does not bold text when the lang is he-IL

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Shlomi Fish, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041007 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041007 Firefox/0.10.1

Mozilla does not bold text when the lang of the html tag is he-IL. As can be
witnessed in the URL, the bolded text is not displayed differntly.

Reproducible: Always
Steps to Reproduce:
1. Go to the URL.
2. The two last paragraphs have font-weigh: bold and <b></b>.


Actual Results:  
They are not bolded.

Expected Results:  
They should be bolded.
What is the output of about:buildconfig?
(Reporter)

Comment 2

13 years ago
about:buildconfig shows:

<<<
about:buildconfig

Build platform
target
i586-mandrake-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.4.1 (Mandrakelinux 10.1 3.4.1-4mdk) 	-Wall -W -Wno-unused
-Wpointer-arith -Wcast-align -Wno-long-long -O2 -fomit-frame-pointer -pipe
-march=i586 -mtune=pentiumpro -pthread -pipe
c++ 	gcc version 3.4.1 (Mandrakelinux 10.1 3.4.1-4mdk) 	-fno-rtti
-fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor
-Wno-long-long -fabi-version=1 -fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
i586-mandrake-linux-gnu --program-prefix= --prefix=/usr --exec-prefix=/usr
--bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share
--includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/lib
--localstatedir=/var/lib --sharedstatedir=/usr/com --mandir=/usr/share/man
--infodir=/usr/share/info --disable-pedantic '--enable-optimize=-O2\
-fomit-frame-pointer\ -pipe\ -march=i586\ -mtune=pentiumpro' --disable-debug
--disable-ldap --disable-tests --disable-mailnews --disable-composer
--enable-strip --enable-crypto --enable-xinerama --with-system-jpeg
--with-system-png --with-system-zlib --enable-default-toolkit=gtk2 --enable-xft
--enable-svg --enable-svg-renderer-cairo
--enable-extensions=cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,negotiateauth
--enable-single-profile --disable-profilesharing --disable-installer
--with-default-mozilla-five-home=/usr/lib/mozilla-firefox-0.10.1
>>>

but it also happens with:

<<<
about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1) 	-Wall -W -Wno-unused
-Wpointer-arith -Wcast-align -Wno-long-long -pedantic -pthread -pipe
c++ 	gcc version 3.3.2 20031022 (Red Hat Linux 3.3.2-1) 	-fno-rtti
-fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor
-Wno-long-long -pedantic -fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--disable-ldap --disable-mailnews
--enable-extensions=cookie,xml-rpc,xmlextras,pref,transformiix,universalchardet,webservices,inspector,gnomevfs,negotiateauth
--enable-crypto --disable-composer --enable-single-profile
--disable-profilesharing --disable-debug '--enable-optimize=-Os -freorder-blocks
-fno-reorder-functions -gstabs+' --disable-tests --enable-official-branding
--enable-default-toolkit=gtk2 --enable-xft --disable-freetype2 --enable-static
--disable-shared
>>>
Worksforme on Linux with both xft and non-xft current trunk builds...

Reporter, do you see this problem with a non-xft build?
(Reporter)

Comment 4

13 years ago
In the non-xft version:

http://xrl.us/dyvt

the bold effect indeed takes place.

(Reporter)

Comment 5

13 years ago
But I do get it in the gtk2+xft trunk.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Comment 7

12 years ago
Seems to be fixed in Mandriva 2006.0, with Firefox v. 1.0.6. I submitted this report so now I'm closing it as WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.