Uninstaller dialog that appears if Firefox is running should have a cancel button

VERIFIED DUPLICATE of bug 233728

Status

()

Firefox
Installer
VERIFIED DUPLICATE of bug 233728
13 years ago
12 years ago

People

(Reporter: Tom Hessman, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

If you run Firefox's uninstaller while Firefox is open, it tells you that
Firefox is running, and that it needs to quit Firefox to continue.  It says that
it will automatically do so when you click OK, but there is no cancel button, so
you are forced to close Firefox and lose any data (I had 3 Bugzilla tabs open,
for example).

Reproducible: Always
Steps to Reproduce:
1. Open Firefox with at least one tab
2. Go to the Add/Remove Programs Control Panel
3. Attempt to uninstall Firefox

Actual Results:  
A window appears telling you that it needs to quit Firefox, and that it will do
so automatically when you click OK.

Expected Results:  
In addition to the OK button, there should be a Cancel button in case you don't
want it to quit Firefox for you.  After it quits Firefox you can still cancel
the uninstallation, but you should be able to cancel it before it forces Firefox
to quit.

*** This bug has been marked as a duplicate of 233728 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.