If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Double address with auto completion

RESOLVED DUPLICATE of bug 261272

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 261272
13 years ago
13 years ago

People

(Reporter: Mike Fedyk, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: TB 0.9 (20041103)

Warning, this bug is timing dependent.

When typing the first part of an address into a new message, I typically type
two letters and then press tab very quickly to get to the subject line. 
Sometimes it leaves the two letters I typed and doesn't auto-complete them, and
other times it shows the the simptoms of this bug which look like:

Mike Fedyk <mfedyk@matchmail.com> >> Mike Fedyk <mfedyk@matchmail.com>

I have a ldap directory lookup setup, but this address is also in my local
address book.

Reproducible: Sometimes
Steps to Reproduce:
1. Type first few letters of email address very quickly (enough to be unique in
your address books)
2. press tab very quickly after typing the above
Actual Results:  
Mike Fedyk <mfedyk@matchmail.com> >> Mike Fedyk <mfedyk@matchmail.com>

Expected Results:  
Mike Fedyk <mfedyk@matchmail.com>
(Reporter)

Comment 1

13 years ago
Created attachment 164801 [details]
Screen shot of compose window

Comment 2

13 years ago
similar to bug 261272, perhaps a dupe.
(Reporter)

Updated

13 years ago
Depends on: 261272

Comment 3

13 years ago
Seems to be related to bug 103917, which as far as I can tell was never fixed. 
I see this behavior on Linux and OS X builds of 0.9 as well as Windows, and I
have seen it on all platforms with every build since 103917 was reported.
(Reporter)

Comment 4

13 years ago
Yeah I've seen bug 103917 in action also.  This bug very similar, and probably
the same problem (I don't know the code, so can't say), but the simptoms are worse.

With bug 103917:
mfe >> Mike Fedyk <mfedyk@matchmail.com>

With this bug:
Mike Fedyk <mfedyk@matchmail.com> >> Mike Fedyk <mfedyk@matchmail.com>

In both cases, I would be typing "mfe" and pressing tab before the
autocompletion appears.  I saw the simptoms of bug 103917 in TB 0.8 and the
simptoms of this bug in tb 0.9 on win2k.
(Reporter)

Comment 5

13 years ago
Yeah I've seen bug 103917 in action also.  This bug very similar, and probably
the same problem (I don't know the code, so can't say), but the simptoms are worse.

With bug 103917:
mfe >> Mike Fedyk <mfedyk@matchmail.com>

With this bug:
Mike Fedyk <mfedyk@matchmail.com> >> Mike Fedyk <mfedyk@matchmail.com>

In both cases, I would be typing "mfe" and pressing tab before the
autocompletion appears.  I saw the simptoms of bug 103917 in TB 0.8 and the
simptoms of this bug in tb 0.9 on win2k.
Depends on: 103917

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 261272 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
No longer depends on: 261272
You need to log in before you can comment on or make changes to this bug.