Enable browser.tabs.opentabfor.bookmarks and browser.tabs.opentabfor.urlbar preferences for opening items in tabs by default

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
15 years ago
a year ago

People

(Reporter: mozillabugs.3.maxchee, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

The hidden preferences browser.tabs.opentabfor.bookmarks and
browser.tabs.opentabfor.urlbar does not do anything in firefox. They are
supposed to load bookmarks/url typed into new tabs, but right now that is not
happening (at least in Windows ME)

Reproducible: Always
Steps to Reproduce:
1. set browser.tabs.opentabfor.bookmarks and browser.tabs.opentabfor.urlbar to true
2. open a website
3. click on a bookmark or type in the urlbar

Actual Results:  
The webpage will be loaded into the current tab

Expected Results:  
The webpage is supposed to be loaded into a new tab

It seems these two preferences are only implemented in the mozilla suite, but
not firefox. I am not sure whether or not this should be classified as an
enhancement, but since it is already implemented in the suite, I suppose bug
would be more appropriate

Comment 1

15 years ago
I would agree with Yuan.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

browser.tabs.opentabfor.bookmarks - true
Also, Options-Advanced-Tabbed Browsing-Select New Tabs Opened From Bookmarks or
History ----box is checked.

Clicking a bookmark opens the page in the active tab. Does not open a new tab.

I did not experience this behavior in the pre-release
Patch in the works.
browser.tabs.opentabfor.urlbar set to false by default.
Bookmarks opened, while browser.tabs.opentabfor.bookmarks is set to true, will
open in a new tab, unless the currently viewed tab is newly created (viewing
about:blank).

URLs entered into the url bar, while browser.tabs.opentabfor.urlbar is set to
true, will also open in a new tab, again unless the currently viewed tab is new.
See bug 230304. Those settings were going to be removed, as they have never done
anything. You can use Ctrl+Click to open them in tabs. Changing this bug to be a
request to add them in, but it will probably be WONTFIX.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows ME → All
Hardware: PC → All
Summary: Preferences to open new tabs for bookmarks and urlbar does not work in firefox → Enable browser.tabs.opentabfor.bookmarks and browser.tabs.opentabfor.urlbar preferences for opening items in tabs by default
I think at least having the option to open bookmarks in a new tab would be a
good idea.

The option to open a new tab for URL bar results is less useful.

Myself, as a user, would like to open bookmarks without having to create a new
tab for them ahead of time.
(In reply to comment #6)
> Myself, as a user, would like to open bookmarks without having to create a new
> tab for them ahead of time.

That's what Ctrl+Click is for.
> That's what Ctrl+Click is for.

That's true, but for the average user (the kind that rarely uses keyboard
shortcuts) I still think it would be useful.

There are many Mac users that end up buying a 2-button mouse for this reason.
(Reporter)

Comment 9

14 years ago
(In reply to comment #7)
> (In reply to comment #6)
> > Myself, as a user, would like to open bookmarks without having to create a new
> > tab for them ahead of time.
> 
> That's what Ctrl+Click is for.

Except most users are not aware of Ctrl+Click and even if they are being made
aware of this shortcut, they won't find it as convinient and natural as right
clicking

I think the Firefox team should have a good look at various HIGs (Gnome's,
Apple's and Microsoft's). I believe the Gnome HIG suggested that most novice
users are not even aware of context menus! That's saying something.
(In reply to comment #8)
> That's true, but for the average user (the kind that rarely uses keyboard
> shortcuts) I still think it would be useful.

The "average user that doesn't use keyboard shortcuts" is not going to benefit
any more from a hidden pref. Without UI, this feature will only benefit advanced
users willing to use about:config.

(In reply to comment #9)
> Except most users are not aware of Ctrl+Click and even if they are being made
> aware of this shortcut, they won't find it as convinient and natural as right
> clicking

You may have meant left-clicking instead of right-clicking, but if not, then
you're confused as to the purpose of this bug. This bug suggests a pref that
makes left clicking bookmarks open them in a new tab instead of the current tab.
Right-clicking works as it has all along.

> I think the Firefox team should have a good look at various HIGs (Gnome's,
> Apple's and Microsoft's). I believe the Gnome HIG suggested that most novice
> users are not even aware of context menus! That's saying something.

That's saying that these users don't want to have to configure every aspect of
their browser to use it. We're trying to avoid a Seamonkey pref bonanza here. 

Basically, I personally see no reason not to introduce the pref for those who
want it, but the argument that this will benefit average-joe users in any way is
not valid in my opinion.
(In reply to comment #10)
> (In reply to comment #8)
> The "average user that doesn't use keyboard shortcuts" is not going to benefit
> any more from a hidden pref. Without UI, this feature will only benefit advanced
> users willing to use about:config.

Yep. I think it would do no harm to hook up the feature now, and let the main
devs design the interface end of it. The feature, if used, would benefit power
users for now, and eventually average users once the options UI displays the
checkbox to toggle it.
(Reporter)

Comment 12

14 years ago
(In reply to comment #10)
> (In reply to comment #8)
> > That's true, but for the average user (the kind that rarely uses keyboard
> > shortcuts) I still think it would be useful.
> 
> The "average user that doesn't use keyboard shortcuts" is not going to benefit
> any more from a hidden pref. Without UI, this feature will only benefit advanced
> users willing to use about:config.
> 
> (In reply to comment #9)
> > Except most users are not aware of Ctrl+Click and even if they are being made
> > aware of this shortcut, they won't find it as convinient and natural as right
> > clicking
> 
> You may have meant left-clicking instead of right-clicking, but if not, then
> you're confused as to the purpose of this bug. This bug suggests a pref that
> makes left clicking bookmarks open them in a new tab instead of the current tab.
> Right-clicking works as it has all along.
> 
> > I think the Firefox team should have a good look at various HIGs (Gnome's,
> > Apple's and Microsoft's). I believe the Gnome HIG suggested that most novice
> > users are not even aware of context menus! That's saying something.
> 
> That's saying that these users don't want to have to configure every aspect of
> their browser to use it. We're trying to avoid a Seamonkey pref bonanza here. 
> 
> Basically, I personally see no reason not to introduce the pref for those who
> want it, but the argument that this will benefit average-joe users in any way is
> not valid in my opinion.


First of all, I do mean left clicking

Secondly, I don't think these prefs could benefit all users, not just power users.

Lastly, having those prefs doesn't mean they are all going to end up in the
options dialogue. It is much sensible to have just one single pref (inside the
options dialogue) which will consolidate the tabbed browsing behaviour prefs for
bookmarks, history, js script, DDE call, urlbar, searchbar etc. (ie. changing
this option dialogue pref will enable/disable all of the above prefs) This will
be even more stragihtfoward than the current tabbed browsing options and I
certainly don't think the end user will find it confusing.
(Reporter)

Comment 13

14 years ago
(In reply to comment #12)
> (In reply to comment #10)
> > (In reply to comment #8)
> > > That's true, but for the average user (the kind that rarely uses keyboard
> > > shortcuts) I still think it would be useful.
> > 
> > The "average user that doesn't use keyboard shortcuts" is not going to benefit
> > any more from a hidden pref. Without UI, this feature will only benefit advanced
> > users willing to use about:config.
> > 
> > (In reply to comment #9)
> > > Except most users are not aware of Ctrl+Click and even if they are being made
> > > aware of this shortcut, they won't find it as convinient and natural as right
> > > clicking
> > 
> > You may have meant left-clicking instead of right-clicking, but if not, then
> > you're confused as to the purpose of this bug. This bug suggests a pref that
> > makes left clicking bookmarks open them in a new tab instead of the current tab.
> > Right-clicking works as it has all along.
> > 
> > > I think the Firefox team should have a good look at various HIGs (Gnome's,
> > > Apple's and Microsoft's). I believe the Gnome HIG suggested that most novice
> > > users are not even aware of context menus! That's saying something.
> > 
> > That's saying that these users don't want to have to configure every aspect of
> > their browser to use it. We're trying to avoid a Seamonkey pref bonanza here. 
> > 
> > Basically, I personally see no reason not to introduce the pref for those who
> > want it, but the argument that this will benefit average-joe users in any way is
> > not valid in my opinion.
> 
> 
> First of all, I do mean left clicking
> 
> Secondly, I don't think these prefs could benefit all users, not just power users.
> 
> Lastly, having those prefs doesn't mean they are all going to end up in the
> options dialogue. It is much sensible to have just one single pref (inside the
> options dialogue) which will consolidate the tabbed browsing behaviour prefs for
> bookmarks, history, js script, DDE call, urlbar, searchbar etc. (ie. changing
> this option dialogue pref will enable/disable all of the above prefs) This will
> be even more stragihtfoward than the current tabbed browsing options and I
> certainly don't think the end user will find it confusing.


Eeerrrrhhh, another typo. I mean "I do think these prefs could benefit all
users, not just power users".
*** Bug 276641 has been marked as a duplicate of this bug. ***
opentabfor.urlbar functionality marked obsolete.

Updated

14 years ago
Attachment #169396 - Attachment is obsolete: true
Comment on attachment 170045 [details] [diff] [review]
Changes revised - limited to opening bookmarks in new tabs

>+	var newTab;

There is no need for this variable. Indentation is wrong as well.

>+	  newTab = gBrowser.addTab(url);
>+	  gBrowser.selectedTab = newTab;

The intermediary newTab isn't necessary, gBrowser.selectedTab =
gBrowser.addTab(url); should work fine.
(Reporter)

Comment 17

14 years ago
also, since the change for bookmarks was made, we should make the same changes
for bookmarks toolbar, history sidebar, go menu and bookmarks menu to keep
things consistent. Lastly, it makes sense to at open new search queries (from
either the searchbar or through smart keywords) in new tabs.

Updated

14 years ago
Attachment #170045 - Attachment is obsolete: true
(In reply to comment #17)
> Lastly, it makes sense to at open new search queries (from
> either the searchbar or through smart keywords) in new tabs.

See https://bugzilla.mozilla.org/show_bug.cgi?id=219532

Updated

14 years ago
Attachment #170702 - Attachment is obsolete: true
This patch implements the browser.tabs.opentabfor.bookmarks pref that was left
unused. Bookmarks are opened in a new tab when this preference is enabled, but
only if the currently viewed page is not blank (a new tab).
Attachment #186283 - Flags: review?(cbutcher)

Updated

14 years ago
Attachment #186283 - Flags: review?(cbutcher) → review?(mconnor)

Updated

14 years ago
Attachment #186283 - Attachment is obsolete: true
Attachment #186283 - Flags: review?(mconnor)
Comment on attachment 186553 [details] [diff] [review]
Conforms to browser.tabs.loadDivertedInBackground option to open tabs in background

loadDivertedInBackground is for external links, not bookmarks.	There's a
loadBookmarksInBackground pref that has UI and would be more appropriate.

Secondly, I think this entire bug is based on a bogus assumption about what the
opentabfor prefs are for.  These prefs controlled whether actions like middle
click opened new tabs or new windows.  Not to make them always open in a new
tab.

As for the patch itself, I don't really think this behaviour is better, or
useful to most people, and its a dupe of multple WONTFIXed bugs.  There are
extensions that allow this functionality, I'd recommend using those.
Attachment #186553 - Flags: review?(mconnor) → review-
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Thanks for the review.

Comment 24

8 years ago
(In reply to Chris Butcher from comment #3)
> Created attachment 169396 [details] [diff] [review]
> Implemented opentabfor.urlbar & opentabfor.bookmarks
> 
> browser.tabs.opentabfor.urlbar set to false by default.

I think this would be great, rather than remove that pref.

Comment 25

a year ago
Please return the function to open in a new tab. Many of the used in Tab Mix plus, and now it doesn't work.
You need to log in before you can comment on or make changes to this bug.