Restarting without exiting Mozilla first gives me error

VERIFIED WORKSFORME

Status

SeaMonkey
General
P3
major
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: Henrik Gemal, Assigned: dougt)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If you on a Win32 machine chooses Start->Restart without first quiting Mozilla 
you'll get an error saying:
"NSPR:EventReciever can shutdown"

Comment 1

19 years ago
Man, I have no idea who would own this.  Doesn't obviously fit any component 
either.  I hate to just pass this off blindly but maybe someone else will have 
a better guess.
Assignee: joki → chofmann
Component: Event Handling → other
QA Contact: janc → leger

Comment 2

18 years ago
Confirmed with 2000-02-17-08-M14 nightly binary on Windows NT, twice.
Each time a dialog came up saying "NSPR:EventReceiver cannot respond to a
shutdown request", and after clicking on [End Task], the same dialog appeared
twice more; after pressing the third [End Task] button, the shutdown continued.

A third time, the dialog said "mozilla.exe cannot respond to a shutdown request"
and again it reappeared twice before the rest of the shutdown procedure 
continued. 

It didn't matter whether the Windows exit was via Start>Shutdown>Restart... or
Start>Shut Down>Shut down... This will annoy anyone who does not regularly
close their browser before shutting down windows.

Most crash-on-exit bugs show up in "Browser-General"; moving this there
for better visibility to those who might have a clue.
Assignee: chofmann → cbegle
Component: other → Browser-General
QA Contact: leger → asadotzler
(Reporter)

Comment 3

18 years ago
I think is a big issue...
Users could be loosing data
Severity: normal → major

Comment 4

18 years ago
I just tried this on NT, and it worked okay. (2000-02-21 debug build) Can 
someone on Win98 confirm that it's still a problem?
(Reporter)

Comment 5

18 years ago
I just tested with the newest build and here's how to reproduce:
- Disconnect from the network.
- Start Mozilla
- Launch mail

Try to restart Windows.

I'll try otherways too...
(Reporter)

Comment 6

18 years ago
Ok.. I think you just have to start Mail and the try to restart.
This will give you an error.
You dont have to be disconnected from the net.

so:
- Start Mozilla
- Start Mail
- restart Windows

Comment 7

18 years ago
wtc, can you look at this?  do you know of this error?
Assignee: cbegle → wtc

Updated

18 years ago
Whiteboard: plevent is no longer part of NSPR. Please reassign to one of brendan,dougt,dp,travis,troy.

Comment 8

18 years ago
plevent is no longer part of NSPR.  Please reassign to 
its new owners (brendan,dougt,dp,travis,troy).
Assignee: wtc → cbegle
Whiteboard: plevent is no longer part of NSPR. Please reassign to one of brendan,dougt,dp,travis,troy.

Comment 9

18 years ago
okay; updating owner to dougt; if it's not you, i guess you can try the next 
person down the line :)
Assignee: cbegle → dougt
(Assignee)

Comment 10

18 years ago
setting milestone.
Target Milestone: M16
(Assignee)

Comment 11

18 years ago
this may have been fixed by 33928.  I will try to verify this tomorrow.
(Assignee)

Comment 12

18 years ago
I could not reproduce by either restarting or by sending a WM_CLOSE message to 
all windows in the process.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

18 years ago
Doesn't work in build 2000042512 on Win2000.
Open Mozilla
choose Start -> Shutdown -> Restart

Gives me the "ending process" dialog...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 14

18 years ago
not going to have time to fix for m16.  m17 bound.
Target Milestone: M16 → M17
(Assignee)

Comment 15

18 years ago
moving out milestones.
Target Milestone: M17 → M26
(Reporter)

Comment 16

18 years ago
Unable to reproduce this on Win2000 anymore....
(Assignee)

Comment 17

18 years ago
has this problem gone away?  marking as worksforme.  QA can you verify on win98,
nt, and 2000?
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
**Mass Spamm**
adding verifyme keyword to all worksforme bugs.
Keywords: verifyme

Comment 19

18 years ago
WFM (win98 92711). I actually restarted my computer testing it, worked just
fine. Verifying.
Status: RESOLVED → VERIFIED

Comment 20

18 years ago
removing verifyme keyword.
Keywords: verifyme
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.