If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

multiple events at the same time cause random display misalignment [weekview]

RESOLVED WORKSFORME

Status

Calendar
Sunbird Only
--
trivial
RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: Rémi Cardona, Unassigned)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I created a php service, which formats my school's schedules into ICS. Third
year students all have their schedule on only one schedule, so there are a lot
of events (up to five) which occur during the same period.

The ICS is well parsed but the calendar view shows some misalignments in random
places (It happens with two events or five, even when there's only one)

Reproducible: Always
Steps to Reproduce:
1. Use ICS attached in comment #2
2. Open Calendar (I use the firefox ext)
3. Go to week 46

Actual Results:  
Some of the events are overlapping by a pixel or two, the distance between
events varies, some lines disapear

Expected Results:  
Things should look flawless :)
(Reporter)

Comment 1

13 years ago
Created attachment 164823 [details]
screen capture for bug report
(Reporter)

Comment 2

13 years ago
Created attachment 164824 [details]
ICS which causes the bug

go to week 46 of the ICS to see the bug
Looks like rounding errors. Not a real big problem imo.
Severity: normal → minor
(Reporter)

Comment 4

13 years ago
On one windows computer that I had forgotten Sunbird was installed on, the
display was fine. It ran a build of Sunbird from August 2004.

So my guess is something changed since then. I do agree the solution has to be
trivial but this "minor regression" looks awful.

I tried looking at the source code of the calendar XPI, but I didn't really know
how the files were linked, what function was called, where it was called and so
on. I gave up an hour later ...

Comment 5

13 years ago
adding week view to summary
Severity: minor → trivial
Summary: multiple events at the same time cause random display misalignment → multiple events at the same time cause random display misalignment [weekview]

Updated

12 years ago
QA Contact: gurganbl → sunbird
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
Attachment #164824 - Attachment mime type: text/calendar → text/plain
After adding valid timezone information to the ICS file, you can open the calendar and there is no overlapping in the week view with the new calendar view code. But it's a good example for the badly needed "War on Boxes" (bug 304741).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.