copy/paste ordered lists should not have numbers

RESOLVED FIXED

Status

()

Core
Serializers
RESOLVED FIXED
14 years ago
5 years ago

People

(Reporter: CyberAlien, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Opera/7.54 (Windows NT 5.0; U)  [en]
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

When copying content of ordered lists Mozilla adds line numbers (or # if line 
numbers aren't set) to copied content.

Reproducible: Always
Steps to Reproduce:
1. Select content of page: http://www.phpbbstyles.com/temp/tests/list_bug/
list_bug.html
2. Press ctrl-c to copy content
3. Paste content in notepad or any other text editor
Actual Results:  
   1. Code line 1
   2. Code line 2
   3. Code line 3


Expected Results:  
Code line 1
Code line 2
Code line 3
(Reporter)

Comment 1

14 years ago
Created attachment 164831 [details]
example of html code
that # is pasted is bug 191842; however, this seems to be working as designed -
you see the numbers on screen, so they should be copied.
(Reporter)

Comment 3

14 years ago
But numbers are not part of content. It is decorational items like borders, 
backgrounds, etc.. so it should not be copied to clipboard. 

Or there should be at least method to hide numbers from copying to make Mozilla 
behave like other browsers do. Line numbers is a good function for highlighting 
code lines, but with Mozilla behavior it removes whole point of function. If 
designer wanted to make lines copiable he should put those numbers in content of 
html page.
it seems you are focussing way too much on code lines. in usual cases, numbered
items belong to the content. having to manually number the lines is really
pointless, we have the technology to do this automatically.

Consider word processors, do you manually number ordered lists there?

also, when you manually number them, you loose the semantics of it...
(Reporter)

Comment 5

14 years ago
Yes, but in word processors when you copy text it copies text, not text with 
line numbers.
This has been brought up before, and the current behavior is very much on purpose...

I'm 99% sure this is a duplicate (possibly of a WONTFIX or INVALID bug).
Whiteboard: DUPEME
(Reporter)

Comment 7

14 years ago
Is there any workaround for this behavior?

Ordered lists are the best way to debug code. Here is example:
http://www.phpbbstyles.com/viewtopic.php?t=1392
And Mozilla invalidates whole idea because of this non-standard behavior.
strange, I thought the best way to debug code was a debugger and a text editor...

(In reply to comment #5)
> Yes, but in word processors when you copy text it copies text, not text with 
> line numbers.

why "line numbers"? it copies the ordered list, together with the numbers.
(checked with ms word 97)


note: bug 61173 lead to the current behaviour. I can't seem to find the bug bz
is referring to.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 10

13 years ago
not a dupe, but I agree w/ bz it's either INVALID or WONTFIX (see bug 61173)
Component: Selection → DOM to Text Conversion
Summary: ordered lists: incorrect copy of content to clipboard → copy/paste ordered lists should not have numbers
Whiteboard: DUPEME

Comment 11

11 years ago
(In reply to comment #9)
> This is an automated message, with ID "auto-resolve01".
> 
> This bug has had no comments for a long time. Statistically, we have found that
> bug reports that have not been confirmed by a second user after three months are
> highly unlikely to be the source of a fix to the code.
> 
> While your input is very important to us, our resources are limited and so we
> are asking for your help in focussing our efforts. If you can still reproduce
> this problem in the latest version of the product (see below for how to obtain a
> copy) or, for feature requests, if it's not present in the latest version and
> you still believe we should implement it, please visit the URL of this bug
> (given at the top of this mail) and add a comment to that effect, giving more
> reproduction information if you have it.
> 
> If it is not a problem any longer, you need take no action. If this bug is not
> changed in any way in the next two weeks, it will be automatically resolved.
> Thank you for your help in this matter.
> 
> The latest beta releases can be obtained from:
> Firefox:     http://www.mozilla.org/projects/firefox/
> Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
> Seamonkey:   http://www.mozilla.org/projects/seamonkey/
> 

In the latest nightly build on MacOS (firefox-3.0a4pre.en-US.mac.dmg) this bug is still not fixed. I would also really like to see this been fixed.
Assignee: selection → nobody
QA Contact: dom-to-text
This was fixed in bug 365805.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Depends on: 365805

Updated

5 years ago
Blocks: 662736
You need to log in before you can comment on or make changes to this bug.