Closed Bug 268074 Opened 16 years ago Closed 15 years ago

Mozilla DMGs are redundantly compressed with gzip

Categories

(SeaMonkey :: Build Config, defect, trivial)

PowerPC
macOS
defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: thephilips, Assigned: bryner)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

All mozilla products for Mac OS X use DMG (Disk Image) format for distribution.
Additionally this disk image is compressed with gzip, so result file has dmg.gz
extension.

Gzip compression is redundant in this case, since DMG file format supports
internally gzip/zlib compression.

This has to be two steps process any way: 1. create disk image and copy
Ff/Tb/Mozilla there; 2. apply compression, what is acomplished with command:

hdiutil convert tmp-firefox-1.0.en-US.mac.dmg \
   -format UDZO -o firefox-1.0.en-US.mac.dmg \
   -imagekey zlib-level=9

Key things are: "-format UDZO" set disk image format to compressed one;
"-imagekey zlib-level=9" set maximum compression level for gzip/zlib.

man hdiutil for more information.

I have checked this on ff1.0rc2 and size of dmg.gz v.s. dmg with compression are
differs about 80 kb (dmg.gz is smaller). But users will not need to go over
additional step of uncompression of dmg and will not have two files on their
desktops - but just one as it must be.

Have fun.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Assignee: mitchell → dbaron
Status: UNCONFIRMED → NEW
Component: Miscellaneous → Tinderbox Configuration
Ever confirmed: true
QA Contact: mitchell → mcafee
Assignee: dbaron → bryner
Component: Tinderbox Configuration → Build Config
Product: mozilla.org → Mozilla Application Suite
Version: other → Trunk
Bug 276570 and bug 276571 filed for Firefox and Thunderbird respectively.
Resummarizing to make this one cover the Application Suite.
Summary: Mozilla products DMGs are redundantly compressed with gzip → Mozilla DMGs are redundantly compressed with gzip
See bug 169602 comment 14 for more reasons why we should do this. Space savings
of dmg.gz over internally zlib-compressed dmg are negligible, users are
presented with a more familiar download process with dmg, and we remove an
unecessary dependency on Stuffit Expander.
Relevant manpage for hdiutil is here:

http://developer.apple.com/documentation/Darwin/Reference/ManPages/man1/hdiutil.1.html

It claims that "Sparse images, encrypted images, and zlib-com-zlib-compressed
images all did not exist in OS X 10.0.x but came into being with 10.1."

Since Mozilla requires 10.1.x, in theory, there should be no backwards
compatibility problem.
Marking bug as fixed
 - See bug 242845 for details.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
We got this in 1.8b1, removing "blocking1.8b2?".
Flags: blocking1.8b2?
You need to log in before you can comment on or make changes to this bug.