If a hostname is very long, the "Confirm setting cookie" dialog is cut off in 640x480

RESOLVED WORKSFORME

Status

SeaMonkey
UI Design
--
minor
RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: Hans Schenker, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug], URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Win98; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

I'm running Firefox 0.10.1 under Windows 98 SE.

If the desktop resolution is set to 640x480, very long cookies names will causes
the "Confirm setting cookie" dialog to be displayed improperly. More specifically:
1) The cookie confirmation window doesn't display the entire warning message.
2) The cookie confirmation window doesn't show the "Deny" button.

This is how you can reproduce the bug:

1) Set Tools -> Options -> Privacy -> Cookies -> Keep Cookies to "ask me every
time".
2) Set your desktop resolution to 640x480.
3) Restart Firefox.
4) Go to this link:
http://cgi.ebay.de/ws/eBayISAPI.dll?ViewItem&category=79913&item=5727948499&rd=1

The page (an auction on the German ebay website) tries to set two cookies with
very long addresses.

There's a screenshot of the bug here:
http://www.geocities.com/snyggdrasil/


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
This is an overall Mozilla bug, I'm not sure if we can really fix this since its
not like we can just wrap the string.
Assignee: firefox → darin
Status: UNCONFIRMED → NEW
Component: Menus → Networking: Cookies
Ever confirmed: true
Product: Firefox → Browser
QA Contact: bugzilla → core.networking.cookies
Summary: If a cookie name is very long, the "Confirm setting cookie" dialog is cut off in 640x480 → If a hostname is very long, the "Confirm setting cookie" dialog is cut off in 640x480
Version: unspecified → Trunk

Updated

13 years ago
Assignee: darin → mconnor
Priority: -- → P4
(Reporter)

Comment 2

13 years ago
If you can't wrap the string, you could make the confirmation window as wide as
necessary to hold the entire string, even if that makes it wider than 480 pixels
in 640x480.
The user could move the extra-wide window to the left if he wanted to view the
entire string or get at the "Deny" button.

Comment 3

13 years ago
Has this been fixed in bug 183700?
Not going to be working on any Seamonkey UI bugs for the foreseeable future. 
You can filter on "danlikesgoats" to delete this spam.
Assignee: mconnor → nobody
Priority: P4 → --

Comment 5

6 years ago
WORKSFORME
Yeah, tested in 640x480 window, cookie manager gives full info
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111017 Firefox/10.0a1 SeaMonkey/2.7a1

Updated

6 years ago
Component: Networking: Cookies → UI Design
Product: Core → SeaMonkey
QA Contact: networking.cookies → ui-design
Whiteboard: [Halloween2011Bug]

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.