Extensions continue to show up as "to be installed after restart" or "to be uninstalled after restart"

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Doug Reich, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041106 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041106 Firefox/1.0RC2

In both Firefox 1.0rc1 and Firefox 1.0rc2 I have no success with installing
extensions.

Reproducible: Always
Steps to Reproduce:
1. I download the extension
2. Notice the extension manager says "this extension will be installed after
restarting firefox"
3. I restart firefox
4. I get the same message as in 2.

The same behavior occurs when trying to disable or uninstall said extensions.
The extensions I've tried this with are:
ChromEdit 0.1.1.1
OpenBook 1.2.0
PasteIP 1.3b3
Web Developer 0.8
User Agent Switcher 0.6
Adblock 0.5.2.039
Actual Results:  
Repeatedly see the 'to be installed' message. Also, the same behavior occurs
when I try to disable or uninstall the extension.

Expected Results:  
I should have some installed extensions!
are you sure that the process is completely terminating?  especially under Linux
I'm really bad for leaving a window on a different workspace and forgetting to
fix it.
(Reporter)

Comment 2

14 years ago
Absolutely. It happens between reboots, and between version upgrades (when I am
certain the profile manager would come up if I had the default profile still in
use). I don't use multiple workspaces anyhow.
(Reporter)

Comment 3

14 years ago
This problem has been resolved. I think the problem was that I hadn't run
firefox as the root user enough times.

Comment 4

14 years ago
resolving per comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 5

12 years ago
(In reply to comment #4)
> resolving per comment 3

I seem to have this problem still. An upgrade to Deer Park alpha 2 keeps showing the "will be installed/uninstalled/upgraded after restart" for a lot of extensions, including:
DOM inspector
Web developer
Extended cookie manager
Greasemonkey...

Personally, I don't think it's the extensions, b/c why else would DOM inspector 1.9a1 have this problem, too?

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060107 Firefox/1.6a1

Comment 6

12 years ago
ypogegrammeni@gmail.com: please if you can provide steps to reproduce and can not find an open bug on it, file one.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.