Closed Bug 268182 Opened 16 years ago Closed 16 years ago

Add Extension: MessageID-Finder for TB/Moz

Categories

(addons.mozilla.org Graveyard :: Public Pages, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: markushossner, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040927
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040927

MessageID-Finder
Name: Markus Hossner
Email: markushossner@gmx.de
Version: 1.9.8
Website: http://messageidfinder.mozdev.org/
XPI: http://downloads.mozdev.org/messageidfinder/messageidfinder-1.9.8.xpi
Works with: Mozilla Suite and Thunderbird


Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Assignee: psychoticwolf → jedsbugs
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: need-testing
Bulk Moving Extension/Theme listing bugs to new component.
(Filter: masslistingspam)
Component: Update → Listings
Product: mozilla.org → Update
Version: other → unspecified
Before it can be listed, an extension must be successfully tested by a third
party. However, I could not verify that this works on Tb0.9 - no new items in
the context menu when selecting a message ID in the source window...
Moving items out of Jed's queue.  If we can get this tested successfully, we
will upload it.
Assignee: jedsbugs → nobody
MessageID-Finder
Name: Markus Hossner
Email: markushossner@gmx.de
Version: 1.9.9
Website: http://messageidfinder.mozdev.org/
XPI: http://downloads.mozdev.org/messageidfinder/messageidfinder-1.9.9.xpi
Works with: Mozilla Suite and Thunderbird

Bugfixes:
- Fixed bug in Tb source view (Jens Bannmann named)
- Fixed bug in local search feature
Sorry for being nitpicking...
1) You currently specifiy a maxVersion of "42" for Thunderbird. Please use
something existing (like "1.0" to indicate 1.0RC compatibility), as UMO will
recect the file otherwise
2) You should add a targetApplication entry for Mozilla Suite, so the UMO
software can automatically add the appropriate entries to the database. See
http://forums.mozillazine.org/viewtopic.php?t=99246

Installs/works/uninstalls fine on Tb1.0RC.
(In reply to comment #5)
> Sorry for being nitpicking...
> 1) You currently specifiy a maxVersion of "42" for Thunderbird. Please use
> something existing (like "1.0" to indicate 1.0RC compatibility), as UMO will
> recect the file otherwise
> 2) You should add a targetApplication entry for Mozilla Suite, so the UMO
> software can automatically add the appropriate entries to the database. See
> http://forums.mozillazine.org/viewtopic.php?t=99246

Thanks. I will correct this. Are these all current bugs you found or do you
still collect? I will wait till you finish for uploading a newer "bugfree" version.
That's all I found. I only tested the context menu in message source (as far as
I understood from the extension homepage, that's all it adds when mnenhy is not
installed). Anyway, I don't have to test *every* single function, the testing
only has to result in a "looks like it adds the UI it describes &
installs/uninstalls fine without breaking the Tb" statement.

Upload the new version, and I'll add the tested+ marker so this bug shows up on
the appropriate queries...
MessageID-Finder
Name: Markus Hossner
Email: markushossner@gmx.de
Version: 1.9.9
Website: http://messageidfinder.mozdev.org/
XPI: http://ftp.scarlet.be/pub/mozdev/messageidfinder/messageidfinder-1.9.9.xpi
(later: http://downloads.mozdev.org/messageidfinder/messageidfinder-1.9.9.xpi)
Works with: Mozilla Suite and Thunderbird

- maxVersion changed
- targetApplication entry for Mozilla Suite added
Marking tested+ according to comment 8.
Whiteboard: need-testing → tested+
Assignee: nobody → Bugzilla-alanjstrBugs
Unfortunately, parsing of RDF is currently done using regular expressions, so I
can't upload this.  If you don't want to wait, the MozillaZine KB has an article
on the format we accept.
Depends on: 271272
MessageID-Finder
Name: Markus Hossner
Email: markushossner@gmx.de
Version: 1.9.9
Website: http://messageidfinder.mozdev.org/
XPI: http://downloads.mozdev.org/messageidfinder/messageidfinder-1.9.9.xpi
Works with: Mozilla Suite and Thunderbird

- Fixed install.rdf (see comment #10)
Assignee: Bugzilla-alanjstrBugs → nobody
Summary: Add Extension: MessageID-Finder → Add Extension: MessageID-Finder for TB/Moz
Whiteboard: tested+
Please use the Developer Control Panel to upload your addon
https://addons.update.mozilla.org/developers/
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → INVALID
AMO BUGSPAM FOR COMPONENT MOVE AND DELETE (FILTER ME)
Component: Listings → Web Site
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.