Comma in ics subject truncates Title after import

RESOLVED INVALID

Status

Calendar
Sunbird Only
RESOLVED INVALID
13 years ago
12 years ago

People

(Reporter: Michael, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

If within the ics file, you have a subject with a comma in the text, the import
works fine, acccept the subject is truncated from the comma and beyond.

WindowsXP SP1 with all fixes
Sunbird 0.2a
Firefox 1.0PR
Calendar 2004110411-cal

Reproducible: Always
Steps to Reproduce:
1. Create a standard ics
2. Edit the SUBJECT line to include a comma.  Ex.  SUBJECT :This is my, life today
3.Run import of ics file

Actual Results:  
This specific event's subject will be:

This is my

Expected Results:  
This is my, life today

I have verified that the same truncation happens in SunBird 0.2a as well, yet
phpiCalander works fine as well Outlook.

Comment 1

13 years ago
Thanks for the report.

I believe Calendar always escapes a comma in text values with a backslash.

Whatever is producing the ics file with an unescaped comma in the title is not
conforming to the specification, RFC2445.  

Text values with comma must place a backslash before a comma or semicolon.
Comma is used as a separator for multiple values in text fields.

See RFC2445 sec4.3.11 
   ... A COMMA character in a
   "TEXT" property value MUST be escaped with a BACKSLASH character
   (US-ASCII decimal 92). A SEMICOLON character in a "TEXT" property
   value MUST be escaped with a BACKSLASH character (US-ASCII decimal
   92). ...

So I suggest resolving this bug as invalid.
(Reporter)

Comment 2

13 years ago
As you state I would also say Calendar should follow the specification and not
ignore the rules as some major vendors do.  I will notify the programmer of the
issue found when they generate an .ics file.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 3

13 years ago
Note that iCalendar 2.0 (RFC2245) is similar to vCalendar 1.0 (Versit
consortium).  If it is a vcs file, and has version 1.0, then it is a vCalendar
1.0 file and the comma need not be escaped.  I don't think calendar/sunbird
currently supports import of vcs differently than ics so that might be the bug.

Does your file say VERSION:1.0 or VERSION:2.0 ?

Comment 4

13 years ago
*** Bug 304674 has been marked as a duplicate of this bug. ***
The bugspam monkeys have been set free and are feeding on Calendar :: Sunbird Only. Be afraid for your sanity!
QA Contact: gurganbl → sunbird
You need to log in before you can comment on or make changes to this bug.