Closed Bug 268300 Opened 16 years ago Closed 14 years ago

{inc} Scrollbar appears, but disappears when focusing link (image with undefined height in nested tables with relative sizes)

Categories

(Core :: Layout: Tables, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041106 Firefox/0.9.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a5) Gecko/20041106 Firefox/0.9.1+

This only happens in recent trunk (1.8a) builds.
I'll attach a testcase.
Unfortunately, I could not make the testcase more simpler than that. The bug
seems to rely on quite some things.
One noticable aspect of the bug is that the image must have an unknown size to
trigger it.

The problem only happens on first load or shift->reload. Resizing, plain
reloading or focusing the link in the page, and the bug (scrollbar) disappears.

Reproducible: Always
Steps to Reproduce:


Actual Results:  
On first load or shift->reload scrollbar appears, image too low, first table
cell (blue border) too high


Expected Results:  
No scrollbar
Attached file testcase
Blocks: 261196
Keywords: testcase
Same problem (using the testcase) under Linux/PPC, using Mozilla (CVS checkout
and compiled a few hours ago). Hardware/OS should be set to All/All.

The problem isn't really the scrollbar (this depends on the window size). But
initially, there's some additional space above and below the green boxes (and
inside the blue box). After the focus (on either the left or right link), this
space disappears.

I confirm that a shift-reload is necessary after the first load to make the bug
reappear.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050428
Firefox/1.0+

Cannot reproduce this anymore.

WFM.
I can still reproduce this, not fixed by bug 240276.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0

Problem appears fixed in this build.  Can someone Verify my finding and close? (lack permission).

I can still see the bug, using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061108 Minefield/3.0a1
Bug occurs in SeaMonkey 2006120701 (pre reflow branch) on Linux.
Bug does not occur in SeaMonkey 2006120801 (post reflow branch) on Linux.
Fixed by bug 300030 it seems, at least on Linux.
OS: Windows XP → All
Summary: Scrollbar appears, but disappears when focusing link (image with undefined height in nested tables with relative sizes) → {inc} Scrollbar appears, but disappears when focusing link (image with undefined height in nested tables with relative sizes)
Fixed on Win32 as well.
Status: NEW → RESOLVED
Closed: 14 years ago
Depends on: reflow-refactor
Resolution: --- → FIXED
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.