Closed Bug 268328 Opened 17 years ago Closed 16 years ago

contents of "save as ..." dialog box painfully slow.

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 159107

People

(Reporter: xaemyl, Assigned: bugzilla)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10 StumbleUpon/1.998
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10 StumbleUpon/1.998

When I try to right-click and save an image from a website (any website), or a
movie link, or even download something from someone's ftp server with Firefox,
the actual contents of the dialog box are drawn painfully slow. I thought
PeerGuardian might have something to do with it, but when I turn it off, it does
the same thing. Slow dialog box drawing.

I didnt see this discussed on the forums, or here on Bugzilla, but since this
only happens with Firefox, and not on any other program on my system, I would
think it's a bug.

Reproducible: Always
Steps to Reproduce:
1. Find a picture (or any file) from a website
2. Right click, save as ...

Actual Results:  
The contents of the dialog box draw painfully slow, listing files anywhere on
the system: the desktop, or a folder I want to save files into ...

Expected Results:  
The contents of the dialog box should draw very quickly, like it does for IE, or
any other program.
This is not an accessibility bug. Please read the component descriptions (under
the "Component" link) before filing a bug. Accessibility is for usability by
persons with disabilities. See http://www.mozilla.org/access for more info.
Assignee: aaronleventhal → firefox
Component: Accessibility → General
QA Contact: bugzilla → firefox.general
check the sice of your downloads.rdf in your profile folder, delete it, see if
its any faster.
(In reply to comment #2)
> check the sice of your downloads.rdf in your profile folder, delete it, see if
> its any faster.

worked for me :)
I was getting annoyed with it to but just thought it had got something to do
with the website....... So having a big list in the downloads manager is a bad
thing... just did a clean up there and the downloads.rdf file went from 114k  to
1 k 

and the manager and save as dialog pops up fast again ...... so it is a bug.....
in a way but for me it is resolved.... 

bug is for me download manager becomes very slow with a moderately big list
expected to be fast still or at least warn u about it somewhere

*** This bug has been marked as a duplicate of 159107 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.