Attempts to go to incomplete URL when typing text and clicking on URL dropdown entry

RESOLVED DUPLICATE of bug 258438

Status

()

Firefox
Address Bar
--
major
RESOLVED DUPLICATE of bug 258438
13 years ago
12 years ago

People

(Reporter: howardwan, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

Typing an previously visited URL into the location bar and clicking on the
dropdown entry causes Firefox to attempt to search for/go to the incomplete URL.

Reproducible: Always
Steps to Reproduce:
1. Click the location bar to select it.
2. Position cursor underneath the bar.
3. Type a previously visited URL (eg. "mozil")
4. Without moving the mouse, click on the URL that appears. (eg.
"http://www.mozillazine.org")
Actual Results:  
The browser attempts to search for "mozil" and redirects me to
http://www.bebits.com/app/2715.

Expected Results:  
Send me to the URL I clicked on, "http://www.mozillazine.org".

This is an EXTREMELY irritating problem for me and occurs very often.  Despite
several bug reports already submitted, it has not been fixed.  It would be
disappointing if it is not fixed before the 1.0 release.

*** This bug has been marked as a duplicate of 168623 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of 168623 ***

Perhaps, but what about actually fixing the bug?  I know very little about this
whole Buzilla process, so pardon my ignorance, but Bug 168623 HAS been submitted
in 2002 and nothing seems to be fixed since then.  The Firefox 1.0 release date
is fast approaching.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 258438 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.