prompts for confirmation on multiple tab close but not quit

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: mtb19@columbia.edu, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3) Gecko/20040913 Firefox/0.10.1

If I have multiple tabs open, and I try to close the window (File -> Close
Window), I am asked if I really want to do that (if browser.tabs.warnOnClose is
true). However, if I try to exit (Firefox -> Quit Firefox), I'm not asked
anything (despite possibly closing multiple windows).

This is especially frustrating for those of us who make mistakes when typing
(since CMD-W is so close to CMD-Q).

Reproducible: Always
Steps to Reproduce:
1. set browser.tabs.warnOnClose to true
2. open a browser window with several tabs
3. try to close the window (you'll be given a warning)
4. click cancel
5. try to quit

Actual Results:  
It silently killed everything.

Expected Results:  
I expected to be warned.
fixed in latest builds; don't remember the bug number.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.