Closed Bug 268369 Opened 18 years ago Closed 18 years ago

Some malformed URLs can lead to Microsoft website on a PC running Win 2000

Categories

(Firefox :: General, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 231720

People

(Reporter: mellowiz, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20041001 Firefox/0.10.1

Mistyping an URL, specifically by putting "http://http" (also alone),
sistematically leads to microsoft.com.
On my PC, running Win 2000 SP4, IE6 and NS7.2 either reply with the "page cannot
be displayed" message or bring me to a search page.
Firefox version is 1.0 PR.

Reproducible: Always
Steps to Reproduce:
1. open Firefox,
2. type "http://http..." (dots indicate nothing or any other address, ex.:
"http://http://www.firefox.com/") in the address bar,
3. press [Enter].

Actual Results:  
Displayed URL is "http://http", displayed web page is
"http://www.microsoft.com/". Pressing [Esc] while focus is on the address bar
shows the correct URL.

Expected Results:  
Pop up a window telling the user that the URL is malformed or unknown.
Duplicate of bug 231720, see bug 265958 comment 1. Please resolve it.

*** This bug has been marked as a duplicate of 231720 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.