{colspan-width} Text in table displayed in two lines

RESOLVED FIXED in M9

Status

()

Core
Layout
P3
normal
RESOLVED FIXED
20 years ago
16 years ago

People

(Reporter: gerardok, Assigned: karnaze (gone))

Tracking

({regression, testcase})

Trunk
All
Windows NT
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

20 years ago
Version: 5.0 (Seamonkey)
Build: Jan_26
Platform: Win NT 4.0 & Linux RedHat kernel 2.0.36

Description:
The text "Search for" in the top banner is split in two lines, while the same
text remains in one single line when displayed in Communicator 4.50 or IE 4.0.

The same issue happens on Linux.

Steps to reproduce:
1. From the Browser, load the page for above URL

Result: "Search for" text split in two lines
Expected: "Search for" displayed in a single line

Updated

20 years ago
Assignee: michaelp → karnaze
Component: Rendering → Layout

Comment 1

20 years ago
The text is inside a table so I'm assigning it to Chris

Updated

20 years ago
Target Milestone: M2

Comment 2

20 years ago
Inserting Milestone info.

Comment 3

20 years ago
Setting all current Open/Normal to M4.

Updated

20 years ago
Summary: [PP]1/26: Text in table displayed in two lines → [4.xP]1/26: Text in table displayed in two lines
(Reporter)

Updated

20 years ago
QA Contact: 4015
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Target Milestone: M4 → M5

Comment 4

19 years ago
moving to m5
(Assignee)

Updated

19 years ago
Target Milestone: M5 → M6
(Assignee)

Comment 5

19 years ago
Moving to M6.
(Assignee)

Comment 6

19 years ago
Moving to M8

Comment 7

19 years ago
I can't reproduce this bug, as lycos has since redesigned its site.  This was
probably a problem with the NOBR tag.

Comment 8

19 years ago
Created attachment 192 [details]
snapshot; www.lycos.com as at April 10th

Comment 9

19 years ago
Created attachment 193 [details]
testcase; distribution of width to colspanned auto-width TD

Comment 10

19 years ago
Gee. This may not be good news, but I had a copy of Lycos from April 10th
showing the bug. So, I've attached it for testing. In compensation, I've
also done a test set that shows (I think) that this is a problem with the
distribution of width to auto-width table cells that a colspanned by another
row. [Case (1) is similar to Lycos; Case (2) shows it working correctly when
the spanning cell is itself auto-width; the other cases are other fixed and
percentage width cases that do not work quite right). See also bug #6404
and http://bugzilla.mozilla.org/showattachment.cgi?attach_id=188
(tested 1999051308 win95).
[TESTCASE] The second attachement here is a very good testcase demonstrating
the problems very well.

Updated

19 years ago
Summary: [4.xP]1/26: Text in table displayed in two lines → {colspan-width} Text in table displayed in two lines
(Assignee)

Comment 12

19 years ago
Moving to M9.

Updated

19 years ago
Whiteboard: [TESTCASE]

Comment 13

19 years ago
Testcase is definitive. Marking as [testcase]...

Problem:
When changing the width of a colspanning TD, the text underneath it "goes wonky".
It is split up into seperate lines and does all sorts of crazy stuff. See
testcase.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 14

19 years ago
Fixed mostly with 7/28 changes. But, please wait for 8/4 build to verify.

Comment 15

18 years ago
vrfy, all of the testcases look the same. This took a year to verify, I hope 
that's long enough :o
Status: RESOLVED → VERIFIED
Keywords: testcase
Whiteboard: [TESTCASE]

Comment 16

17 years ago
The testcase has regressed between 2000-11-2804 and 2001-01-11.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Updated

17 years ago
Keywords: regression

Comment 17

17 years ago
I will look into it, in order to deblock my patch for bug 42187.

Comment 18

17 years ago
fix checked in
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Updated

16 years ago
QA Contact: gerardok → amar
You need to log in before you can comment on or make changes to this bug.