Implement network.protocol-handler.external​.* prefs (no GUI)

RESOLVED FIXED in Camino0.9

Status

Camino Graveyard
Preferences
RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: Marcello Testi, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

unspecified
Camino0.9
PowerPC
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.4.1) Gecko/2002 - Netscape 6.2, Mac OS X
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:0.9.4.1) Gecko/2002 - Netscape 6.2, Mac OS X

Gecko asks user for confirmation before opening external protocols, unless the
protocols are in a whitelist. network.protocol-handler.external​.* prefs are the
way to go to implement such whitelist. The current situation (0.8.2 RC) sees
Camino asking for confirm. before opening mailto: and news: links, which are
whitelisted by default in FF.

Reproducible: Always
Steps to Reproduce:
1. Go to the top of this page
2. Click on tha mail link of the reporter

Actual Results:  
A sheet appears asking for confirmation

Expected Results:  
No sheets for mailto: and news: protocols, as discussed in
https://bugzilla.mozilla.org/show_bug.cgi?id=173010
(Assignee)

Updated

13 years ago
Blocks: 261393
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Camino0.8

Comment 1

13 years ago
*** Bug 269065 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

13 years ago
Created attachment 166867 [details] [diff] [review]
adds prefs a la firefox
(Assignee)

Updated

13 years ago
Attachment #166867 - Flags: review?(joshmoz)

Updated

13 years ago
Target Milestone: Camino0.8 → Camino0.9

Updated

13 years ago
Attachment #166867 - Flags: review?(joshmoz) → review+

Comment 3

13 years ago
landed on trunk and branch
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.