Nested <q></q> tags are not rendered properly

RESOLVED DUPLICATE of bug 24861

Status

()

Firefox
General
--
enhancement
RESOLVED DUPLICATE of bug 24861
14 years ago
14 years ago

People

(Reporter: Chas Owens, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

From the HTML 4.01 standard:
    User agents should render quotation marks in a language-sensitive
    manner (see the lang attribute). Many languages adopt different
    quotation styles for outer and inner (nested) quotations, which 
    should be respected by user-agents.

English is one of those langauges.  Nested quotes should use the ' character not
".  An example follows.

He said <q>She said <q>I think this is a he said/she said sort of thing.</q></q> 

should be rendered as

He said "She said 'I think this is a he said/she said sort of thing.'"

Reproducible: Always
Steps to Reproduce:
1. nest <q></q> tags
2. view page


Actual Results:  
<q></q> is always rendered as "" even when it is nested.

Expected Results:  
<q></q> should be rendered as '' if it is already in a <q></q>

Comment 1

14 years ago
This is already fixed on the main development trunk.  It will appear in FF when
FF returns to the trunk for v1.1.

*** This bug has been marked as a duplicate of 24861 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.