Error when filtering mails from POP3 to IMAP account

VERIFIED DUPLICATE of bug 210614

Status

VERIFIED DUPLICATE of bug 210614
14 years ago
14 years ago

People

(Reporter: navlelo, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0) Opera 7.52  [en]
Build Identifier: version 0.9 (20041103)

I have one main IMAP account, and several POP3 accounts. I transfer all incoming 
mails from the POP3 accounts to folders on the IMAP account. I have set up 
filters to do the job, but it doesn't work. I get the error "The messages could 
not be filtered to folder "xxxxx" because another operation is in progress." and 
the filter is not executed. Since filters run automatically only at first check, 
i have to run them manually on every account afterwards.

The IMAP account is first on my account list.

Reproducible: Always
Steps to Reproduce:
1. Have one IMAP account and at least one POP3 account
2. Sett filters to transfer mails from a POP3 account to the IMAP account
3. receive POP3 mail

Actual Results:  
I get the error message "The messages could not be filtered to folder "xxxxx" 
because another operation is in progress." and the filter is not executed

Expected Results:  
Transfer incoming mail from POP3 account to specified folder on IMAP account.

I had the same problem on an earlier T-bird version (0.7.x).

I guess this is a design problem - that T-bird can only work with one account at 
a time, and it is probably still working with another task on the IMAP account 
when it tries to execute the POP3 filter.

Comment 1

14 years ago
Filtering from POP to IMAP already has three bugs against it:
 bug 66391, bug 180094, bug 210614
The short story is that such filters generally don't work automatically, but do 
work when run manually on the IMAP folder.

The general problem of trying to filter mail to an account that is in the 
process of retrieving mail itself is bug 168648.

Comment 2

14 years ago
J. Bøckman, bug 210614 has been fixed to allow this sort of filtering to occur 
correctly.  Are you still experiencing your problem?

If so, this bug is surely a duplicate of bug 168648; please mark it so.

If the problem is gone, it was probably a side effect of 210614; either mark 
this bug as a dupe of that, or as:  Resolved | WorksForMe
(Reporter)

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 210614 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.