If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Browser delays loading other tabs while one is locked waiting for data

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Richard Aspden, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041103 Firefox/1.0RC2

Requesting Firefox to load a page from a slow server, then opening a new tab (or
tabs) and attempting to load a new site (or sites) results in the new page
requests to hang until the original tab begins to load.

Reproducible: Sometimes
Steps to Reproduce:
1. Request a page from a server which is slow to respond.
2. Open a new tab, and attempt to load up another site. I often open 2 or 3.
Actual Results:  
The second and third tab didn't begin loading until the first tab had recieved
some initial data.

Expected Results:  
Tabs to render asynchronously, and to load up regardless of the other tab's status.

They were different sites, so unlikely to be slowed by network traffic. As soon
as the first tab started loading, the second and third ones came up immediately.

Comment 1

13 years ago
running Windows XP.  Browser opens correctly when first used after boot up. 
Once closed and an attempt is made to reopen it the browser loads in teh back
ground, without any display and I have to reboot windows to get it corrected. 
The system manager upon shut down says Firefox is running but it doesn't display
on my screen.  Thus I must reboot.  I'm running Firefox 1.03 also tryed to
reinstall Firefox and it continues to do this.  Started upon update last week.

Comment 2

12 years ago
I see this same behavior on gentoo linux running on amd64 (compiled 32-bit for
x86).  

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Often when I open a bookmark group in tabs half of the tabs will take upwards of
30 seconds or more to load.  When they do load they all load within a second of
each other.  I've opened the various connection settings to 500 to no avail.

There definitely seems to be some kind of locking/blocking/synchronous behavior
here.  I see it on major sites (yahoo/slashdot/etc) as well as on sites being
served from localhost.
(Reporter)

Comment 3

12 years ago
Seems to be a networking library issue, at a wild guess. I'd say it's waiting
for "free connections" to push through to the next lot, or it's being buffered
elsewhere, or something. Unfortunately, I've no idea where to start on this one...

(In reply to comment #2)
> Often when I open a bookmark group in tabs half of the tabs will take upwards of
> 30 seconds or more to load.  When they do load they all load within a second of
> each other.  I've opened the various connection settings to 500 to no avail.
> 
> There definitely seems to be some kind of locking/blocking/synchronous behavior
> here.  I see it on major sites (yahoo/slashdot/etc) as well as on sites being
> served from localhost.

Assignee: bugs → nobody
Reporter, do you still see the problem with the latest nightly build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
no reply to comment 4 after more than a month, closing WFM.

Reporter and commenters, please reply to this report if you continue to experience this problem with a more recent version of Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.