Closed Bug 268518 Opened 16 years ago Closed 16 years ago

SIGTRAP [@ CopyRgn]

Categories

(Core Graveyard :: GFX: Mac, defect)

PowerPC
macOS
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 266570

People

(Reporter: j4nu5.n6, Assigned: sfraser_bugs)

References

()

Details

(Keywords: crash)

Crash Data

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040825 Camino/0.8.1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.2) Gecko/20040825 Camino/0.8.1

Both Camino 0.8.1 and Firefox 1.0RC2 crash after afew seconds of loading that page.

Reproducible: Always
Steps to Reproduce:
1. type "http://www.kmb.hk/chinese.php?" in address
2. wait a few seconds

Actual Results:  
crashed/ unexpected quit.

Expected Results:  
showing the page fine.
Could you provide any Talkback incident reports?
Or an OS X crash report (please attach it via "create new attachment" link )
Keywords: crash
Sure, I have sent a few which I have typed "http://kmb.com.hk/chinese.php?" in
the URL field of the Talkback agent.  Here is the newest incident ID:TB1844382E.
CC pinkerton@aol.net

Maybe he can help with this stack (seems to be useless) because this crashes
inside of a carbon libary (?)

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB1844382E

Incident ID: 1844382
Stack Signature	Foundation.500.56.0 + 0x6c740 (0x90a5c740) 2ef76812
Product ID	Camino08
Build ID	2004110211
Trigger Time	2004-11-09 20:11:15.0
Platform	MacOSX
Operating System	Darwin 7.6.0
Module	Foundation.500.56.0 + (0006c740)
URL visited	http://kmb.com.hk/chinese.php
User Comments	
Since Last Crash	15477 sec
Total Uptime	15477 sec
Trigger Reason	SIGTRAP: Trace Trap: (signal 5)
Source File, Line No.	N/A
Stack Trace 	
Foundation.500.56.0 + 0x6c740 (0x90a5c740)
Summary: crash on page → SIGTRAP [@ Foundation.500.56.0]
I haven't seen the SIGTRAP trigger before, but talking to dbaron we thought it
was something that the debugger would catch and weren't sure why Talkback was
seeing it.  Would an assertion trigger the SIGTRAP type?
reporter: could you try using crashreporter instead of talkback? attach the log.
i'll see about poking this over the weekend, and i've asked some people on
irc.freenode.net #macdev for help.

(also, if you have devtools, you could try using xcode to debug camino ...)
Attached file Crash log of camino
The last 6 crashes was caused by loading the page.

Sorry for the late reply.
thanks
Assignee: general → sfraser
Component: Browser-General → GFX: Mac
QA Contact: general
Summary: SIGTRAP [@ Foundation.500.56.0] → SIGTRAP [@ CopyRgn]
Dupe of bug 266570: this is a bug in the Java 1.4.1 plugin (see duplicate bug
for more info).  Work around is to disable the two libraries and revert back to
Java 1.3.1.

*** This bug has been marked as a duplicate of 266570 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
This bug is fixed in version 0.8.7 of the Java Embedding Plugin, which
was just released.

http://javaplugin.sourceforge.net/

I confirm that the "http://www.kmb.hk/chinese.php" web page no longer crashes
Camino and Firefox once I have get JEP 0.8.7 installed.
Product: Core → Core Graveyard
Crash Signature: [@ CopyRgn]
You need to log in before you can comment on or make changes to this bug.