Let users select their email template for notifications

RESOLVED WONTFIX

Status

()

Bugzilla
Email Notifications
--
enhancement
RESOLVED WONTFIX
13 years ago
2 years ago

People

(Reporter: Onno Garms, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624 Netscape/7.1 (ax)

Different people have different needs for newchangedmail.
So it would be nice if everybody could configure his bugmail indiviually
(Maybe Prefs / Email settings / Advanced)

Same for voteremovedmail and whinemail (and passwordmail, if you are at it).

Parameters should provide fields to set defaults for these mails.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
(Reporter)

Updated

13 years ago
Version: unspecified → 2.17.7

Comment 1

13 years ago
Sounds a bit difficult for common users, IMHO. You already have the choice to
receive bug mails or not. What else do you need? The kind of information the
mail contains? If yes, what kind of?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> Sounds a bit difficult for common users, IMHO. 

That's why the parameters should provide the possiblility to set a default.

> You already have the choice to
> receive bug mails or not. What else do you need? The kind of information the
> mail contains? If yes, what kind of?

The reason why I asked for that is that I'd like to include product and
component in the newchangedmail (see Bug 175222) for me (being responsible for
several products) but not for the end users or code writers (who have only one
product).

I admit that this is much less urgent than including product and component in
the newchangedmail at all (see Bug 175222, which has a working patch since
yesterday).


Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → email-notifications
QA Contact: mattyt-bugzilla → default-qa

Comment 4

13 years ago
We could, at the least, provide a few different choices for newchangedmail, once
it's templatized, based on some common user needs.
Severity: normal → enhancement
Depends on: 275636
OS: Windows XP → All
Hardware: PC → All

Comment 5

13 years ago
We could have a template giving the info that everybody needs with a
user-specific bit at the end.
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> We could have a template giving the info that everybody needs with a
> user-specific bit at the end.

That won't do for me, because I want to include the product in the mail header
for people working in more than one project, but not for customers.

Comment 7

13 years ago
What about:

use user-specified template if it exists, default template if it doesn't.

Comment 8

13 years ago
(In reply to comment #7)
> use user-specified template if it exists, default template if it doesn't.

  I think the ideal would be to have a list of admin-created templates that
could be picked from by the end-user, if they wanted. That is, at least, my plan
if I implement this bug.
(Reporter)

Comment 9

13 years ago
(In reply to comment #7)
> What about:
> 
> use user-specified template if it exists, default template if it doesn't.

Great

Comment 10

13 years ago
(In reply to comment #8)

> I think the ideal would be to have a list of admin-created templates that
> could be picked from by the end-user, if they wanted. That is, at least, my plan
> if I implement this bug.

You're still going to need a default.

Hm. No comment in 3½ years. I'm not sure what the reporter wants, but doesn't the table of checkboxes under Email Prefs solve it (60 checkboxes at b.m.o)?
(Reporter)

Comment 12

9 years ago
The reason that there has been no comment for 3,5 years is that I've said everything to describe my wish. I still would like the feature to be implemented. This bug is about introducing a per-user-template for the mail. That cannot be solved by any number of checkboxes.

Comment 13

7 years ago
The newchangedmail parameter is gone.
Summary: Make newchangedmail a per user pref instead of a parameter → Let users select their email template for notifications

Comment 14

2 years ago
Besides the reporter himself, nobody else has shown a lot of interest in this feature (no voters besides the reporter), and almost no comments besides the reporter too.

It's already hard enough to maintain a single good-looking template to not have to manage several of them, especially because a user-made template would have huge security implications. -> WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.