start.mozilla.org/firefox/ (in Firefox 1.0.x default bookmarks) is 404

RESOLVED FIXED

Status

Marketing
General
--
major
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Waldo, Assigned: Chris Beard)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Firefox 1.0 bookmarks contains a bookmark for the Firefox Start Page.  The link
used is:

http://start.mozilla.org/firefox/

This redirects to <http://www.google.com/firefox/>.  However, the slash at the
end causes the link to misfire, and Google responds with a Page Not Found error.
 We need to add a redirect on m.o for this so that this:

http://start.mozilla.org/firefox/

...redirects to this (note the lack of ending slash):

http://www.google.com/firefox

Ccing the webmaster dummy owner so people watching it know about this...it
should be easily fixable by either the cheap way (.htaccess) or the more
difficult way (lower-level hacking by someone at the Mozilla Foundation).

Comment 1

13 years ago
This is a google bug, but fairly important because we have default bookmarks
pointing here.
Severity: normal → major

Comment 2

13 years ago
I would fix this but I'm not sure how to change a start.m.o redirect.  If it 
was just a normal www.m.o I could fix it.

Anyone know how start.m.o is set up?

Comment 3

13 years ago
Nicholas, I already said that this was a google bug (start.mozilla.org is a
CNAME to www.google.com).

Comment 4

13 years ago
This also affects PR1 as http://start.mozilla.org/firefox/ is the default home
page for Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1

Comment 5

13 years ago
We need to get Google to fix it.
-> Marketing.
Assignee: bugs → cbeard
Component: Web Site → General
Product: Firefox → Marketing
QA Contact: chofmann
Summary: Firefox Start Page bookmark does not redirect properly → start.mozilla.org/firefox/ (in Firefox default bookmarks) is 404
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

13 years ago
Will make contact with our technical contact at Google to get this resolved.

Comment 7

13 years ago
um, wouldn't it be easy enough to change the default bookmark to 

http://start.mozilla.org/firefox

without the terminal slash, since that works just fine?
(In reply to comment #7)
And how do you intend to do this on all the machines that have had a recent
version of Firefox installed (in addition to your own machine)?
(Assignee)

Comment 9

13 years ago
Adding myk@mozilla.org as perhaps we could add redirect of
http://start.mozilla.org/firefox/ to be http://www.google.com/firefox as well as
the current, and correct, http://www.google.com/firefox/ for the time being as
we work to have Google make the necessary fix on their end.
(Assignee)

Comment 10

13 years ago
Of course, now I read back to bsmedberg's comment about it being a CNAME, so
will ping Google again to get status on this.  (Unless there is some sysadmin
DNS hackery that could make it better?)

Comment 11

13 years ago
related to bug 266774 ?
(In reply to comment #11)
> related to bug 266774 ?

That bug was about changing the link to the page on Firefox's side. This bug is
about fixing the old link that appeared in previous builds, on Google's side.
Ping.

There has to be some sysadmin hackery that can fix this. If Google won't someone
on Mozilla.org's end needs to.

Please give a status update on this bug.
Summary: start.mozilla.org/firefox/ (in Firefox default bookmarks) is 404 → start.mozilla.org/firefox/ (in Firefox 1.0.x default bookmarks) is 404
*** Bug 299886 has been marked as a duplicate of this bug. ***

Comment 15

12 years ago
http://www.google.com/firefox/ seems to be back!

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.