Bookmark toolbar keeps collapsing and will not expand

VERIFIED DUPLICATE of bug 266737

Status

()

VERIFIED DUPLICATE of bug 266737
14 years ago
12 years ago

People

(Reporter: jjablonski, Unassigned)

Tracking

1.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

The bookmark toolbar seems to randomly collapse as if it is too long for the
window. Instead of the first bookmarks being visible and getting the
double-arrow for those that would be too long, the -entire- toolbar collapses to
the double-arrows. Clicking the double-arrows brings up all the bookmarks as a
drop down list. The only way I've been able to restore it is to expand the width
of the Firefox window.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




Didn't happen on 1.0PR. Only surfacing on v1.0.

I haven't noticed a particular set of actions that causes the bookmark toolbar
to collapse, but it happens quite a bit and is quite annoying. I'll try and see
if I can discern a way to reproduce the collapsing.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 266737 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

14 years ago
I would like to add a comment here about this being a duplicate:
I am not doing what is outlined in bug #266737.

One, I am not opening the Bookmark Manager at all and moving bookmarks around.
I'm not even adding any bookmarks at all.

Also, my bookmark toolbar only fills up 2/3 of my Firefox window. And the ">>"
thing appears after I switch back and forth between programs. The icon also
appears on the -left- side of my screen, not the right where it should appear
when there are indeed too many bookmarks for the screen

Finally, I would point out that #266737 affected 1.0RC1, where this one I've
only noticed in 1.0. (Tho admittedly I did not install the RC.)

Now, not knowing the underlying code, what fixes #266737 may fix this as well. I
just want to point out that the description of bug #266737 does not match this one.

thx,
john
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Version: unspecified → 1.0 Branch
Assignee: vladimir → vladimir+bm

Comment 3

14 years ago
I noticed that this bug is marked as unconfirmed, and thus wanted to add some
confirmation, from a user's perspective. Since I installed Firefox 1.0 I have
been encountering the same problem as described in the original bug report, with
the same symptoms in all particulars. I'm using it on Windows XP. The toolbar
seems to collapse most frequently when I have many other apps/windows open and
switch back and forth between them. The way I've been fixing it is by unchecking
"Bookmarks Toolbar" in the View->Toolbars menu, and then re-checking it. That
seems to open up the toolbar again. The bookmarks I have on my toolbar do not
fill the whole window -- as with the original bug report, my toolbar fills about
2/3 of my browser window. The ">>" button that appears when the toolbar
collapses doesn't appear to have any effect on anything (doesn't expand the
toolbar). I used the Preview Release for 1.0 and did not encounter this until I
installed the official 1.0 release. It's a minor thing but I can imagine a
less-dedicated Firefox user becoming very frustrated at having to continually
reopen the toolbar. Thanks! 

Comment 4

14 years ago
this started with firefox 1.0 and is a bit annoying

Comment 5

14 years ago
This happens to me reliably on Windows XP Professional with SP2 when I use the
"Switch User" feature and log in as another user on the system.

jd

Comment 6

14 years ago
A quick workaround is to press Ctrl-B twice quickly (restores the Bookmarks
Toolbar).  I also use Fast User Switching and see this bug frequently.

Comment 7

14 years ago
This bug started from Firefox 1.0. I use Windows XP.It is really annoying. There
is no ovreflow in my Bookmarks folder- the icons fit nicely. This happens after
Firefox has been open a while, and comes up in any new window I open. The way I
deal with it is right-click on the overflow symbol (>>), Customize, and click on
Restore Default Set. 
This is a dupe, the code that makes this happen exists in only one place, we
just need to figure out why its sometimes improperly collapsing the whole
toolbar.  Regardless of steps to reproduce, it's the same bug.

*** This bug has been marked as a duplicate of 266737 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Assignee: vladimir+bm → nobody
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.