XML Parsing Error, Upgrading from .9pr to 1.0 results in a dead browser.

VERIFIED DUPLICATE of bug 246623

Status

()

Firefox
Installer
--
critical
VERIFIED DUPLICATE of bug 246623
14 years ago
12 years ago

People

(Reporter: Dave, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: 1.0 Nov 11th

I tried to upgrade by clicking on the red ^ icon. It downloaded 1.0, tried to 
install and the browser crashed. I restarted the PC and
now everytime I try to start Firefox, I see this error...

XML Parsing Error: undefined entity Location 
chrome://browser/content/browser.xul Line Number 910, Column 33: 
chromedir="locale.dir;">__________^

Reproducible: Didn't try
Steps to Reproduce:
1.Have 6 tabs open
2.Click the red ^ upgrade button and upgrade from 1.0pr to 1.0 
3.
Actual Results:  
I can't uninstall Mozilla now. Do I delete the dir and try again or install 
over it?

Expected Results:  
Upgraded to todays 1.0 release.

Safe mode doesn't work.
(Reporter)

Comment 1

14 years ago
Created attachment 165325 [details]
Screen shot
(Reporter)

Comment 2

14 years ago
My system info -> http://servoe.com/sys.txt (save as)
(Reporter)

Updated

14 years ago
Summary: XML Parsing Error, Upgrading from 1.0pr to 1.0 results in a dead browser. → XML Parsing Error, Upgrading from .9pr to 1.0 results in a dead browser.

Comment 3

14 years ago
I've got the exact same error after trying to use the auto updater to upgrade 
from PR1 to 1.0.
XML Parsing Error: undefined entity Location: 
chrome://browser/content/browser.xul Line Number 910, column 33:
chromedir="&locale.dir;">
---------------------------------^

After downloading the latest nightly build and installing, this is the error I 
get:
firefox.exe - entry point not found
The procedure entry point ??1nsCOMPtr_base@@QAE@XZ could not be located in the 
dynamic link library xpcom.dll.

I think the feedback agent report number on the original crash is TB1876514Z 
if it helps.

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 246623 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.