Closed Bug 268676 Opened 20 years ago Closed 20 years ago

Add inline / real-time spell checking support

Categories

(Thunderbird :: Message Compose Window, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 58612

People

(Reporter: MagicFab, Assigned: mscott)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1 Mnenhy/0.6.0.104
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10.1 Mnenhy/0.6.0.104

I'd like to propose the addition of real-time spell checking (as you type). This
was previously proposed in Mozilla Mail & News in #58612 . There seems to be a
working patch there.

This blog post mentions more details and has a screenshot of the implementation
in Mozilla 1.8 for Lindows:
http://www.xulplanet.com/ndeakin/article/284

Reproducible: Always
Steps to Reproduce:
1. Open a new email composition window
2. Type several mispelled words

Actual Results:  
The speller does not automatically check wrong words as you type.

Expected Results:  
The speller should automatically check wrong words as you type.

The rationale behind this is that the general usability of the spell checker is
greatly diminished when it has launches right after composition, right before
sending. It introduces an extra delay which when optionally disabled should keep
real time spell-checking operational. In other words, keep the "Check spelling
before sending" composition option but also have a new, separate "Check spelling
as you type" composition option.

Filing this as normal, since it's preventing migration for several installs I am
doing in small businesses where this feature is critical, and I have had several
comments about this being a blocker for wider adoption in office environments.
Link to the referenced bug: Bug 58612
Changing OS to ALL
Reviewer: please check if this should be marked as dependent on Bug 58612
OS: Linux → All
Duping for now, although mscott might reopen this or one of the earlier
thunderbird duplicates if he feels the need when the fe code needs to be ported.

*** This bug has been marked as a duplicate of 58612 ***
Status: UNCONFIRMED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Aren`t Mail & News bugs/RFEs separate from TB's ?

Found this extension for TB, haven'nt tested it (!):

http://kb.mozillazine.org/index.phtml?title=Thunderbird_:_FAQs:_Inline_Spell
http://www.supportware.net/mozilla/#ext8
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.