Trunk crash on exit after opening stand-alone msg window. [@ nsMsgStatusFeedback::~nsMsgStatusFeedback]

VERIFIED FIXED

Status

MailNews Core
Backend
--
critical
VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: Bienvenu, Assigned: Bienvenu)

Tracking

(4 keywords)

Trunk
x86
Windows 2000
crash, fixed-aviary1.0, regression, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(1 attachment, 1 obsolete attachment)

1.95 KB, patch
Scott MacGregor
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

13 years ago
if you open a stand-alone message window and then do a file exit, you crash in
the nsMsgStatusFeedback destructor. fix upcoming
(Assignee)

Comment 1

13 years ago
Created attachment 165330 [details] [diff] [review]
proposed fix

null check, not scary :-)
(Assignee)

Updated

13 years ago
Attachment #165330 - Flags: superreview?(mscott)

Updated

13 years ago
Attachment #165330 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 2

13 years ago
Created attachment 165334 [details] [diff] [review]
better fix

use a comptr, and make atom a member var, not a static...
(Assignee)

Updated

13 years ago
Attachment #165330 - Attachment is obsolete: true
(Assignee)

Updated

13 years ago
Attachment #165334 - Flags: superreview?(mscott)
(Assignee)

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
Summary: crash on exit after opening stand-alone msg window. → crash on exit after opening stand-alone msg window. [nsMsgStatusFeedback::~nsMsgStatusFeedback]

Comment 3

13 years ago
Comment on attachment 165334 [details] [diff] [review]
better fix

much better
Attachment #165334 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 4

13 years ago
*** Bug 268743 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Severity: normal → critical

Comment 5

13 years ago
*** Bug 268903 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

13 years ago
*** Bug 269380 has been marked as a duplicate of this bug. ***

Comment 7

13 years ago
This was also a topcrash on the MozillaTrunk, but disappeared after 11/9, so I'm
guessing this fix took care of the regression there as well.  Just wanted to
confirm.

Bienvenu:  I'm assuming you checked this patch into the Trunk also, right?
Keywords: topcrash
Summary: crash on exit after opening stand-alone msg window. [nsMsgStatusFeedback::~nsMsgStatusFeedback] → Trunk crash on exit after opening stand-alone msg window. [nsMsgStatusFeedback::~nsMsgStatusFeedback]

Updated

13 years ago
Summary: Trunk crash on exit after opening stand-alone msg window. [nsMsgStatusFeedback::~nsMsgStatusFeedback] → Trunk crash on exit after opening stand-alone msg window. [@ nsMsgStatusFeedback::~nsMsgStatusFeedback]
(Assignee)

Comment 8

13 years ago
yes, I did (which is why I marked it fixed)

Comment 9

13 years ago
V.fixed per Talkback data.  No crashes since 11/9 builds.

Updated

13 years ago
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Crash Signature: [@ nsMsgStatusFeedback::~nsMsgStatusFeedback]
You need to log in before you can comment on or make changes to this bug.